Page 1 of 1

Latest update will not run on macOS Catalina

Posted: Thu Nov 14, 2019 11:09 pm
by DavidAKnopf
Downloaded update today, 14 Nov 2019, and it will not launch on macOS Catalina. Instead, there is an error dialog:

"XnViewMP" can't be opened because apple cannot check it for malicious software.
The software needs to be updated. Contact the developer for more information.

Re: Latest update will not run on macOS Catalina

Posted: Fri Nov 15, 2019 6:23 am
by xnview
i have not yet catalina to test. No problem with 0.93.1?

Re: Latest update will not run on macOS Catalina

Posted: Fri Nov 15, 2019 7:00 am
by AndreasW
I have the same problem.
Bildschirmfoto 2019-11-15 um 08.00.20.png

Re: Latest update will not run on macOS Catalina

Posted: Fri Nov 15, 2019 7:05 am
by AndreasW
And no, this problem did not occur with 0.93.1.

Unfortunately, this fatal problem could not be detected during beta test, because there was no beta version for macOS.

Re: Latest update will not run on macOS Catalina

Posted: Fri Nov 15, 2019 8:25 am
by xnview
AndreasW wrote:
Fri Nov 15, 2019 7:05 am
And no, this problem did not occur with 0.93.1.

Unfortunately, this fatal problem could not be detected during beta test, because there was no beta version for macOS.
Could you try to re-download this package, and tell me if it works now?

Re: Latest update will not run on macOS Catalina

Posted: Fri Nov 15, 2019 8:35 am
by AndreasW
xnview wrote:
Fri Nov 15, 2019 8:25 am
Could you try to re-download this package, and tell me if it works now?
It does work. Thank you!

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 1:02 pm
by rdinsdale
xnview wrote:
Fri Nov 15, 2019 8:25 am
Could you try to re-download this package, and tell me if it works now?
I can confirm that this version still doesn't work in Catalina (10.15.1) for me. I still get the same error:

"“XnViewMP.app” can’t be opened because Apple cannot check it for malicious software."

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 4:37 pm
by Colamike
rdinsdale wrote:
Sat Nov 16, 2019 1:02 pm
xnview wrote:
Fri Nov 15, 2019 8:25 am
Could you try to re-download this package, and tell me if it works now?
I can confirm that this version still doesn't work in Catalina (10.15.1) for me. I still get the same error:

"“XnViewMP.app” can’t be opened because Apple cannot check it for malicious software."
J'ai le même problème et j'ai écrasé l'ancienne version, donc incapable d'utiliser le logiciel malheureusement. Comment faire ? D'avance merci

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 4:39 pm
by Colamike
rdinsdale wrote:
Sat Nov 16, 2019 1:02 pm
xnview wrote:
Fri Nov 15, 2019 8:25 am
Could you try to re-download this package, and tell me if it works now?
I can confirm that this version still doesn't work in Catalina (10.15.1) for me. I still get the same error:

"“XnViewMP.app” can’t be opened because Apple cannot check it for malicious software."
Same case for me, help us please

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 5:35 pm
by cday
Colamike wrote:
Sat Nov 16, 2019 4:37 pm
J'ai le même problème et j'ai écrasé l'ancienne version, donc incapable d'utiliser le logiciel malheureusement. Comment faire ? D'avance merci

Disponible encore ici XnView MP 0.93.1 ou à long terme ici Old_Versions ... :D

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 6:59 pm
by AndreasW
 
Strange. For me, the problem is definitely fixed.
 
 
Bildschirmfoto 2019-11-16 um 19.54.22.jpg

Re: Latest update will not run on macOS Catalina

Posted: Sat Nov 16, 2019 11:42 pm
by rdinsdale
It seems that Catalina quarantines the software, so even installing older versions gives the same error.
I got around it eventually by this method:
https://apple.stackexchange.com/questio ... licious-so

Re: Latest update will not run on macOS Catalina

Posted: Mon Nov 18, 2019 1:44 pm
by xnview
Colamike wrote:
Sat Nov 16, 2019 4:39 pm
Same case for me, help us please
you can authorize XnView MP in Settings>Security, i search for a solution

Re: Latest update will not run on macOS Catalina

Posted: Wed Dec 11, 2019 10:10 am
by Colamike
Done it's running now
Thx