0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
fractl
Posts: 26
Joined: Fri Sep 26, 2014 10:15 am

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by fractl » Thu Jan 30, 2020 12:47 pm

I am also using xfce4 on my Ubuntu 18.04 install. I just ran

Code: Select all

sudo apt install qt5-default
and it did do a bunch of installing, but doesn't seem to have made a difference. Same error message:

Code: Select all

~$ xnview
Cannot mix incompatible Qt library (version 0x50907) with this library (version 0x50c06)
Aborted (core dumped)

User avatar
juozas
Posts: 19
Joined: Sun Sep 27, 2009 11:42 am
Location: Lithuania
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by juozas » Thu Jan 30, 2020 12:56 pm

installing qt5ct and setting variable QT_QPA_PLATFORMTHEME to qt5ct in /etc/X11/Xsession.d/56xubuntu-session and then rebooting fixed the problem for me (running xubuntu). Check my previous (updated) post for more information.
Сделано в СССР

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by xnview » Thu Jan 30, 2020 4:17 pm

MaxMeier wrote:
Wed Jan 29, 2020 2:46 pm
the same problem exists with a fresh new installation of Linux MINT 19.3 xfce 64bit.
XnView MP 0.95 was installed from the Linux DEB 64bit.
The XnView version 0.94.x is working properly.
which message do you have?
Pierre.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by xnview » Thu Jan 30, 2020 4:26 pm

fractl wrote:
Thu Jan 30, 2020 12:47 pm

Code: Select all

~$ xnview
Cannot mix incompatible Qt library (version 0x50907) with this library (version 0x50c06)
Aborted (core dumped)
I'm not able to reproduce on ubuntu 18.04

Which Qt libs do you have

Code: Select all

apt list --installed
Pierre.

MaxMeier
Posts: 2
Joined: Wed Jan 29, 2020 2:33 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by MaxMeier » Fri Jan 31, 2020 5:27 am

xnview wrote:
Thu Jan 30, 2020 4:17 pm
MaxMeier wrote:
Wed Jan 29, 2020 2:46 pm
the same problem exists with a fresh new installation of Linux MINT 19.3 xfce 64bit.
XnView MP 0.95 was installed from the Linux DEB 64bit.
The XnView version 0.94.x is working properly.
which message do you have?
The version XnViewMP 0.95, which is now on your server, works :D !

Thanks a lot!

Max

DanPF
Posts: 13
Joined: Tue Sep 11, 2018 3:29 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by DanPF » Fri Jan 31, 2020 4:33 pm

As the OP, I tried this on my system and I am happy to report it works for me too. Thank you so much.

zygos29
Posts: 2
Joined: Sat Jan 25, 2020 1:22 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by zygos29 » Sat Feb 01, 2020 5:47 pm

Current download of version 0.95 works fine on Linux mint 19,3 cinnamon

User avatar
fractl
Posts: 26
Joined: Fri Sep 26, 2014 10:15 am

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by fractl » Sat Feb 01, 2020 8:48 pm

xnview wrote:
Thu Jan 30, 2020 4:26 pm
fractl wrote:
Thu Jan 30, 2020 12:47 pm

Code: Select all

~$ xnview
Cannot mix incompatible Qt library (version 0x50907) with this library (version 0x50c06)
Aborted (core dumped)
I'm not able to reproduce on ubuntu 18.04

Which Qt libs do you have

Code: Select all

apt list --installed
I've just reinstalled the 0.95 .deb over my working copy of 0.92 and nothing has changed there.

Code: Select all

~$ apt list --installed
...
qt-at-spi/bionic,now 0.4.0-8 amd64 [installed,automatic]
qt5-default/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed]
qt5-gtk-platformtheme/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed,automatic]
qt5-qmake/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed,automatic]
qt5-qmake-bin/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed,automatic]
qtbase5-dev/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed,automatic]
qtbase5-dev-tools/bionic-updates,now 5.9.5+dfsg-0ubuntu2.4 amd64 [installed,automatic]
qtchooser/bionic,now 64-ga1b6736-5 amd64 [installed,automatic]
qtcore4-l10n/bionic,bionic,now 4:4.8.7+dfsg-7ubuntu1 all [installed,automatic]
qttranslations5-l10n/bionic,bionic,now 5.9.5-0ubuntu1 all [installed,automatic]
...
UPDATE: Just did the editing of that system settings file that @juozas mentioned (not feeling entirely comfortable, as I'd never have figured that out myself) and rebooted, and it works. So - all good on this side too. Thanks for the help @juozas. 8)

jarau
Posts: 2
Joined: Mon Feb 03, 2020 2:07 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by jarau » Mon Feb 03, 2020 2:10 pm

I have the same issue with v0.95. I'm using Ubuntu 18.04. Downgrade to 0.94.3 work without any trouble. And yes the trick with qt5ct works but this is not what I want.

wgc214
Posts: 7
Joined: Thu Sep 20, 2018 4:25 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by wgc214 » Mon Feb 03, 2020 3:56 pm

Your help would be appreciated. I am using Fedora 31 with Cinnamon desktop. I cannot get .095 to work. Version 0.94.3 works just fine.

When I try to start xnview.sh, this is the result:
[XnView]$ ./xnview.sh
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Aborted (core dumped)

----------

These are the qt5 packages installed on my system:
qt5-qtdeclarative-5.13.2-1.fc31.x86_64
qt5-qttools-libs-designer-5.13.2-3.fc31.x86_64
qt5-qtquickcontrols-5.13.2-1.fc31.x86_64
qt5-qtspeech-5.13.2-1.fc31.x86_64
qt5-qtx11extras-5.13.2-1.fc31.x86_64
qt5-qttools-common-5.13.2-3.fc31.noarch
qt5-qtbase-5.13.2-2.fc31.x86_64
qt5-qtbase-common-5.13.2-2.fc31.noarch
qt5-qtbase-gui-5.13.2-2.fc31.x86_64
qt5-qtsvg-5.13.2-1.fc31.x86_64
qt5-qtquickcontrols2-5.13.2-1.fc31.x86_64
qt5-qtgraphicaleffects-5.13.2-1.fc31.x86_64
qt5-qtspeech-speechd-5.13.2-1.fc31.x86_64
qt5-qtwayland-5.13.2-2.fc31.x86_64

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by xnview » Tue Feb 04, 2020 9:46 am

wgc214 wrote:
Mon Feb 03, 2020 3:56 pm
Your help would be appreciated. I am using Fedora 31 with Cinnamon desktop. I cannot get .095 to work. Version 0.94.3 works just fine.
I've fixed the .deb & tgz, please download it again
Pierre.

jarau
Posts: 2
Joined: Mon Feb 03, 2020 2:07 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by jarau » Tue Feb 04, 2020 10:31 am

Thanx a lot. Now it to work. I've tested on two Ubuntu 64bit 18.04.3 systems.

User avatar
juozas
Posts: 19
Joined: Sun Sep 27, 2009 11:42 am
Location: Lithuania
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by juozas » Tue Feb 04, 2020 2:29 pm

If using deb and installing through apt, you have to add a parameter to force XnView to reinstalled (add --reinstall to apt-get command line), as long as your apt version support apt-get install ./filename.deb syntax (all newer versions does it fine), otherwise you can use dpkg to install it, though it will not install runtime dependencies automatically.
Сделано в СССР

wgc214
Posts: 7
Joined: Thu Sep 20, 2018 4:25 pm

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by wgc214 » Tue Feb 04, 2020 5:03 pm

I downloaded the latest tgz file, unpacked it, and copied XnView and all files beneath to my home directory. It fails with exactly the same messages as I previously reported.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.95.2 Fails to Load in Linux Mint 19.3, Cinnamon

Post by xnview » Fri Feb 07, 2020 2:15 pm

wgc214 wrote:
Tue Feb 04, 2020 5:03 pm
I downloaded the latest tgz file, unpacked it, and copied XnView and all files beneath to my home directory. It fails with exactly the same messages as I previously reported.
It seems that the problem comes from libfontconfig, QT 5.12 requires libfontconfig 1.13
Pierre.

Post Reply