Ratings and color markers are not saved

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Tue Apr 14, 2020 7:24 amYes.
could you try to rename the .ini?
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

Yes. After I did, XnView created a new one on startup and also recreated the database files. My problem also disappeared. I then changed the ini back to the one I had before and now my settings are restored but the problem did not re-appear. Now I am curious, do you have any idea what happened?
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Tue Apr 14, 2020 8:35 am Yes. After I did, XnView created a new one on startup and also recreated the database files. My problem also disappeared. I then changed the ini back to the one I had before and now my settings are restored but the problem did not re-appear. Now I am curious, do you have any idea what happened?
you have restored the old .ini, and now all is good???
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

Nah, it's not. I mixed up the several copies of the ini. I am now using my original ini again and the problem re-appeared. See here for the ini diff: viewtopic.php?f=62&t=40190&p=162143#p162171
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Wed Apr 15, 2020 3:37 pm Nah, it's not. I mixed up the several copies of the ini. I am now using my original ini again and the problem re-appeared. See here for the ini diff: viewtopic.php?f=62&t=40190&p=162143#p162171
I've checked the .ini, and you don't use 'Catalog'
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

Then I don't know what catalog is (in my second post in this thread I asked for it). What I do is:
  • double-click a file
  • file opens in XnView MP in fullscreen mode
  • I put ratings on file(s)
  • I press Enter
  • XnView changes to what I called the "catalog" or "browser" mode
  • ratings are gone
  • I put ratings on files here
  • I close XnView and re-open
  • ratings are gone
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Fri Apr 17, 2020 3:33 pm Then I don't know what catalog is (in my second post in this thread I asked for it). What I do is:
Catalog is used to save some information about files like rating
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

Oh it's not a view at all. Is that the part of XnView that generates the XnView.db and Thumbs.db? Because I now see I can enable "catalog" in the settings. The ini I use is quite old, I have no idea if I ever consciously activated or deactivated the catalog but now, it is disabled, yes. So if I disable the catalog and saving ratings to xmp, it is normal that ratings and color markers are not saved?
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Sat Apr 18, 2020 9:16 am Oh it's not a view at all. Is that the part of XnView that generates the XnView.db and Thumbs.db? Because I now see I can enable "catalog" in the settings. The ini I use is quite old, I have no idea if I ever consciously activated or deactivated the catalog but now, it is disabled, yes. So if I disable the catalog and saving ratings to xmp, it is normal that ratings and color markers are not saved?
In your settings, XMP export is not enabled
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

I know. As I said in my initial post, when I enable xmp export, the problem disappears. I showed you a configuration where the problem occurs.

My question was, is it expected that I cannot save ratings and color markers when both catalog and xmp export are deactivated?
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Sat Apr 18, 2020 9:45 am My question was, is it expected that I cannot save ratings and color markers when both catalog and xmp export are deactivated?
yes, in this case there is no way to store rating. Perhaps a warning should be shown
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

I agree. This was a long thread and a lot of misunderstanding that could have been avoided. I would suggest that if ratings cannot be stored, ratings can also not be set at all. It is confusing that when I rate an image in fullscreen, the rating is just gone when I leave fullscreen (but not XnView). So, not an actual bug, but confusing and unexpected behaviour. Thank you for the explanation though!
User avatar
xnview
Author of XnView
Posts: 37892
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Ratings and color markers are not saved

Post by xnview »

Konzertheld wrote: Sat Apr 18, 2020 12:25 pm I agree. This was a long thread and a lot of misunderstanding that could have been avoided. I would suggest that if ratings cannot be stored, ratings can also not be set at all. It is confusing that when I rate an image in fullscreen, the rating is just gone when I leave fullscreen (but not XnView). So, not an actual bug, but confusing and unexpected behaviour. Thank you for the explanation though!
Ok, i'll add a message
Pierre.
Konzertheld
Posts: 40
Joined: Sun Feb 27, 2011 9:43 pm

Re: Ratings and color markers are not saved

Post by Konzertheld »

Got it with the update to 0.96.1 today. Thanks! But did I get it right? The message says "...cannot be saved if metadata export or catalog is deactivated". That implies you need both. But I only need one of those, right? So I'd suggest using a phrase like "if both metadata export and catalog are deactivated". :)