[1.7.0] BIG image problem

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, helmut, xnview, Dreamer

Kadet
Posts: 104
Joined: Thu Oct 20, 2022 7:23 pm

[1.7.0] BIG image problem

Post by Kadet »

Win11 23H2 / AMD RYZEN / 32 GB RAM

There is big image Van Gogh from Wikipedia https://upload.wikimedia.org/wikipedia/ ... roject.jpg (30,000 × 23,756 / 205.1 MB).
It is opening OK in XnView MP.
But when I try to enlarge the image by 200%, it only enlarges half, the lower half is a quirk.
Van_Gogh.jpg
Saving PNG file gives only half source the image, the second is black.

IMHO, it's problem with allocate bigger memory on Windows (clear installation, not on virtual machine).
You do not have the required permissions to view the files attached to this post.
ckit
XnThusiast
Posts: 2568
Joined: Tue Feb 17, 2004 1:11 am
Location: QLD, Australia

Re: [1.7.0] BIG image problem

Post by ckit »

Confirmed, my lower half is completely black!
I won't bother saving as format as it will be the same as what I'm seeing now
AMD Ryzen 3 3300X 3.8Ghz, 16Gb DDR4, RX6600XT with Dell U2520D at 2560x1440@60Hz
Windows 11 Pro x64 23H2, PowerToys and Wintoys
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [1.7.0] BIG image problem

Post by xnview »

what do you have in 'Settings>View - high zoom quality'?
Pierre.
Kadet
Posts: 104
Joined: Thu Oct 20, 2022 7:23 pm

Re: [1.7.0] BIG image problem

Post by Kadet »

xnview wrote: Tue Apr 09, 2024 6:08 am what do you have in 'Settings>View - high zoom quality'?
Bicubic in both Out/In.
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [1.7.0] BIG image problem

Post by xnview »

try bilinear, take less memory
Pierre.
Kadet
Posts: 104
Joined: Thu Oct 20, 2022 7:23 pm

Re: [1.7.0] BIG image problem

Post by Kadet »

I'm afraid there has been a misunderstanding.

When I wrote "enlarge" I didn't mean pressing the '+' key, but 'Shift'+'S' and setting here 200% enlarge. After this operation that only the upper half is correct and the lower half is incorrect.
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [1.7.0] BIG image problem

Post by xnview »

yes. try bilinear, take less memory
Pierre.
Kadet
Posts: 104
Joined: Thu Oct 20, 2022 7:23 pm

Re: [1.7.0] BIG image problem

Post by Kadet »

In fact, when I set the magnification type to bilinear, the image enlarged correctly.
However, the idea is to enlarge the image using any technique, e.g. Mitchell, Lanczos.
I have enough memory, that's not the problem.
Big_image.jpg
IMHO, it is a problem of proper memory allocation, which in certain circumstances (large image,
zoom method) is poorly managed.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [1.7.0] BIG image problem

Post by xnview »

Kadet wrote: Wed Apr 10, 2024 11:39 am In fact, when I set the magnification type to bilinear, the image enlarged correctly.
However, the idea is to enlarge the image using any technique, e.g. Mitchell, Lanczos.
I have enough memory, that's not the problem.
Big_image.jpg
IMHO, it is a problem of proper memory allocation, which in certain circumstances (large image,
zoom method) is poorly managed.
Ok, the bilinear function is not the same for other filters. But i can't reproduce. In 100%, the picture is correctly displayed (with bicubic), and not in 200%. You can reproduce each time?
Pierre.
User avatar
user0
XnThusiast
Posts: 1595
Joined: Sat May 09, 2015 9:37 am

Re: [1.7.0] BIG image problem

Post by user0 »

to reproduce:
0. clean unzipped version
1. open image
2. press SHIFT+S to open Resize Image
- set Mode to %, value to 101%
- set Method to.. see below
- press OK
get image with black line in the bottom, sometimes crash

Code: Select all

Nearest neighbor	ok
Bilinear		ok
Hermite			bug
Gaussian		bug
Bell			bug
BSpline			bug
Mitchell		bug
Lanczos			bug
Hanning			bug
Cubic			bug
Lanczos2		bug
crash_dumps_resize_to_101percent.zip

ps: memory consumption same as Kadet's - never come to 100% (I have 32Gb as well)
You do not have the required permissions to view the files attached to this post.
Kadet
Posts: 104
Joined: Thu Oct 20, 2022 7:23 pm

Re: [1.7.0] BIG image problem

Post by Kadet »

xnview wrote: Wed Apr 10, 2024 1:07 pm Ok, the bilinear function is not the same for other filters. But i can't reproduce. In 100%, the picture is correctly displayed (with bicubic), and not in 200%. You can reproduce each time?
Yes, it happens every time.
Height black bottom is depending on % zoom. For 200% it's 50%. For 150% it's 25%. For 105% is a little.
When I try 110% program crash me every time. I click Update to send You info from crash.

I hope You find the bug.

Edit.
PS. When I saved a zoomed image by bilinear to png I can't read it - not in XnView, not in Windows Photo.
PS2. Save As jpegli is OK.
User avatar
xnview
Author of XnView
Posts: 43723
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: [1.7.0] BIG image problem

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.