Page 1 of 2

can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 7:59 am
by drugo
Hi
i upgrade xnconverter and it does't works anymore
i gave me error like api-ms-win-crt-runtime-l1-1-0.dll is not present on the system

i have copied this files inside the main folder , i got another error and it stoped to work

i use the portable version on my usb stick at work , they use windows 7 ,

how can i fix it?
i tried to install older version and the installation version , no luck

what files should i copy inside the main program to let it work?
thanks

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 8:03 am
by xnview
Window 7 x64?

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 8:07 am
by drugo
xnview wrote:
Fri Feb 01, 2019 8:03 am
Window 7 x64?
hi
yes , windows 7 64bit
i tried the 32bit version ,but it doesn't work eighter
even the older version
thanks

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 8:24 am
by xnview
drugo wrote:
Fri Feb 01, 2019 8:07 am
xnview wrote:
Fri Feb 01, 2019 8:03 am
Window 7 x64?
yes , windows 7 64bit
Win 7 Pro SP 1?

Strange, on a clean Win 7 x64 SP1, i have c:\windows\system32\api-ms-win-*, not you?
even the older version
which older version?

could you try to install
https://aka.ms/vs/15/release/vc_redist.x86.exe
https://aka.ms/vs/15/release/vc_redist.x64.exe

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 8:54 am
by drugo
xnview wrote:
Fri Feb 01, 2019 8:24 am
drugo wrote:
Fri Feb 01, 2019 8:07 am
xnview wrote:
Fri Feb 01, 2019 8:03 am
Window 7 x64?
yes , windows 7 64bit
Win 7 Pro SP 1?

Strange, on a clean Win 7 x64 SP1, i have c:\windows\system32\api-ms-win-*, not you?
even the older version
which older version?

could you try to install
https://aka.ms/vs/15/release/vc_redist.x86.exe
https://aka.ms/vs/15/release/vc_redist.x64.exe
hi
i have c:\windows\system32\api-ms-win-* ,but not api-ms-win-crt-runtime-l1-1-0.dll
i tried to install both links no luck
it worked few week ago :/
thanks

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 9:18 am
by drugo
xnview wrote:
Fri Feb 01, 2019 8:24 am
drugo wrote:
Fri Feb 01, 2019 8:07 am
xnview wrote:
Fri Feb 01, 2019 8:03 am
Window 7 x64?
yes , windows 7 64bit
Win 7 Pro SP 1?

Strange, on a clean Win 7 x64 SP1, i have c:\windows\system32\api-ms-win-*, not you?
even the older version
which older version?

could you try to install
https://aka.ms/vs/15/release/vc_redist.x86.exe
https://aka.ms/vs/15/release/vc_redist.x64.exe
hi
can i please have the link of the zip 64bit and 32bit of XnConvert Version 1.75 ?
i don't want to get virus downloading on other site please?
thanks

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 9:27 am
by cday
drugo wrote:
Fri Feb 01, 2019 9:18 am
Can I please have the link of the zip 64bit and 32bit of XnConvert Version 1.75 ?
I don't want to get virus downloading on other site please?

Earlier versions

Scroll down... :D

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 9:47 am
by drugo
cday wrote:
Fri Feb 01, 2019 9:27 am
drugo wrote:
Fri Feb 01, 2019 9:18 am
Can I please have the link of the zip 64bit and 32bit of XnConvert Version 1.75 ?
I don't want to get virus downloading on other site please?

Earlier versions

Scroll down... :D
hi
is it the official site?
i have download the 1.77 and work perfectly!
don't know why 1.78 & 1.79 don't work :? :?
thanks

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 11:08 am
by xnview
drugo wrote:
Fri Feb 01, 2019 9:47 am
i have download the 1.77 and work perfectly!
don't know why 1.78 & 1.79 don't work :? :?
I need to understand you have not the api-ms-win-crt-runtime-l1-1-0.dll

1.78/1.79 use newer version of win32 api

Re: can i download an older version portable? or fix the new version

Posted: Fri Feb 01, 2019 2:42 pm
by drugo
xnview wrote:
Fri Feb 01, 2019 11:08 am
drugo wrote:
Fri Feb 01, 2019 9:47 am
i have download the 1.77 and work perfectly!
don't know why 1.78 & 1.79 don't work :? :?
I need to understand you have not the api-ms-win-crt-runtime-l1-1-0.dll

1.78/1.79 use newer version of win32 api
hi
but api-ms-win-crt-runtime-l1-1-0.dll is included in Visual C++2015 ,isn't it?

not all the compters have installed it
thanks

Re: can i download an older version portable? or fix the new version

Posted: Sat Feb 02, 2019 8:24 am
by xnview
drugo wrote:
Fri Feb 01, 2019 2:42 pm
but api-ms-win-crt-runtime-l1-1-0.dll is included in Visual C++2015 ,isn't it?
I don't use VC 2015, but 2017. And the file should be included in vc_redist 2017
If you copy this file in the XnConvert folder, it's work? You have the same problem for XnView MP, right?
Please try to install this runtime

Re: can i download an older version portable? or fix the new version

Posted: Mon Feb 04, 2019 11:47 am
by xnview
drugo wrote:
Fri Feb 01, 2019 2:42 pm
not all the compters have installed it
do you have tried?

Re: can i download an older version portable? or fix the new version

Posted: Mon Feb 04, 2019 2:49 pm
by drugo
xnview wrote:
Mon Feb 04, 2019 11:47 am
drugo wrote:
Fri Feb 01, 2019 2:42 pm
not all the compters have installed it
do you have tried?
hi
i have installed all the windows updates and optionals update , and now works
this api is related to a specially to raccomandated update
but it's not preset to a normal w7 sp1 64bit but just like a said to raccomandated update
is there a gain to use this api dll?
thanks

Re: can i download an older version portable? or fix the new version

Posted: Mon Feb 04, 2019 3:37 pm
by xnview
drugo wrote:
Mon Feb 04, 2019 2:49 pm
but it's not preset to a normal w7 sp1 64bit but just like a said to raccomandated update
Oh ok, i have all updates
is there a gain to use this api dll?
it's seems now used by lastest vc dll

Re: can i download an older version portable? or fix the new version

Posted: Tue Feb 05, 2019 9:55 am
by xnview
drugo wrote:
Mon Feb 04, 2019 2:49 pm
but it's not preset to a normal w7 sp1 64bit but just like a said to raccomandated update
do you know which update?