Problem with extension when I use multiple cores converting process

XnConvert Multi Platform - Windows, MacOSX, Linux

Moderators: XnTriq, helmut, xnview

IzoFox
Posts: 2
Joined: Thu Aug 04, 2022 6:49 pm

Problem with extension when I use multiple cores converting process

Post by IzoFox »

Hi!
I have a bug.
When I convert CR2 images, or other format, like WebP, or PNG to JPG and I enable checkbox "Use multiple CPU cores" and set them to maximum (32 threads in my case). I get converted images, but they are with extension of original images.

Like they were CR2 and after converting to JPG they have CR2 extension.
If I will convert them twice and more, the extensions will be changed to JPG.
If I will convert them in one thread, the extensions also will be change to JPG correctly.

I've uploaded a video with the problem.
https://drive.google.com/drive/folders/ ... sp=sharing

Thank you!
I will wait for your answer.
User avatar
xnview
Author of XnView
Posts: 38711
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Problem with extension when I use multiple cores converting process

Post by xnview »

do you have enabled 'Preserve extension'?
Pierre.
IzoFox
Posts: 2
Joined: Thu Aug 04, 2022 6:49 pm

Re: Problem with extension when I use multiple cores converting process

Post by IzoFox »

xnview wrote: Thu Aug 11, 2022 11:58 am do you have enabled 'Preserve extension'?
Yes, it have been enabled.
I've disabled it and it works good now, I think.

Why this checkbox don't have affect, when I convert in one thread?