Page 2 of 2

Re: Forum search function bug?

Posted: Sun Dec 25, 2011 4:13 pm
by Peter2
XnTriq wrote:...First, you have to copy & paste this code...
Thanks XnTriq, it works fine now.

Peter

Re: Forum search function bug?

Posted: Sun Dec 25, 2011 9:15 pm
by XnTriq
Peter2 wrote:Thanks XnTriq, it works fine now.
You're welcome, Peter 8)

There's an alternative method for Internet Explorer:
If you save the following text as SearchUrl.reg and import it into the Windows system registry, you just have to enter xn-g keyword into the address bar of the browser to search the forum with Google or xn-y keyword to search it with Yahoo.

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\XN-G]
@="http://www.google.com/search?as_sitesearch=newsgroup.xnview.com&q=%s"

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl\XN-Y]
@="http://search.yahoo.com/search?vs=newsgroup.xnview.com&p=%s"

workaround the dumb forum search

Posted: Mon Sep 01, 2014 8:52 pm
by GeorgD
Dear XnTriq, thank your for suggestions how to workaround :) the dumb forum search :twisted:

Could we add a link from http://newsgroup.xnview.com/search.php to this forum thread so it's much easier to find solutions? Or even add a form that auto-fills google?

Background of this post: I wanted to search for the exact phrase "Save as", but exact phase search is not possible according to the phpBB developers and the workaround (searching directly in the DB system) is not available for me. Then, again not possible, so I tried +Save +as but both words are ignored because they are "too common". Well, what shall I say, the name of the function is "save as" so I need to search for that... Similar issue for "Format settings", exact phrase does not work, searching for +Format +settings works but the term "format" is ignored, so I get hundreds of hits which are too many to look through. I am sure that only a fraction also contains "Format", so it would be helpful to be able to force the search system to accept that word. The option "Search for all terms or use query as entered" on http://newsgroup.xnview.com/search.php does not what its name suggests :(
Finally I searched the forum and found this topic. The stuff with specific firefox search provider is not suitable on that computer, so I used plain google search.

Solution: I went to https://www.google.com/ and entered "Save as" +inurl:"?f=60" site:newsgroup.xnview.com where the first part contains my search terms, the inurl-part restricts to topics in forum MP - Suggestions (when you open that forum, the URL in the browser's address bar is http://newsgroup.xnview.com/viewforum.p ... u][/i][/b] so that is where I got the forum number from) and the last part restricts to XnView domain (I don't want to search the whole www). Oh, the first hit was what I was looking for...a fixes suggestion :-)

Re: workaround the dumb forum search

Posted: Tue Sep 02, 2014 4:15 am
by XnTriq
GeorgD wrote:Could we add a link from http://newsgroup.xnview.com/search.php to this forum thread so it's much easier to find solutions? Or even add a form that auto-fills google?
Welcome back, GeorgD :D

I've just added Google Site Search to the forum's “Advanced search” page.
For now, it's very basic and only works with the default board style (“prosilver”), because I'm a little short on time. I'll edit the “subsilver” theme accordingly ASAP.

Re: workaround the dumb forum search

Posted: Tue Sep 02, 2014 11:08 pm
by GeorgD
XnTriq wrote:Welcome back, GeorgD :D
Thank you :) With XnView classic that "just worked", I simply had no need to be here ;) but as XnView MP offers some cool new features like rating & color tags but is still a beta, I'm here more often again :)
XnTriq wrote:I've just added Google Site Search to the forum's “Advanced search” page.
Wow, that looks really good and seamless! And it works! :D
Mh, is it low effort to change the title "Search query" to "phpBB forum search query" and to make one border around both "Search query" and "Search options"? This would help users to instantly recognize that we have google and phpBB search and that the options only apply to the latter one.

Best regards, Georg

Re: Forum search function bug?

Posted: Sun Sep 28, 2014 6:24 pm
by Peter2
XnTriq wrote:.... into a text editor and save it as xnview.google.xml.
In case you're a Firefox user, xnview.google.xml has to be placed in this directory:...
I found this old thread from 24.12.2011 again (by incident ..), added it to my new machine (and modified it for my own site too :wink: ) - it it runs again, so I want to again "thanks" to XnTriq.

By the way:
Maybe the code could / should be added to Firefox search-machines?
https://addons.mozilla.org/de/firefox/e ... rch-tools/

Peter

Re: Forum search function bug?

Posted: Fri Jan 09, 2015 6:05 pm
by Marunos
Is this same for Chrome users?

Re: Forum search function bug?

Posted: Thu Jan 15, 2015 11:45 pm
by XnTriq
Sorry for the late response. I'm subscribed to this topic, but for some reason I didn't get any reply notifications. :?

I'll add an OpenSearch plug-in to the forum ASAP. As of now, this is only available for the wiki (“XnView Wiki”) and the bug tracker (“MantisBT: Text Search” + “MantisBT: Issue Id”).

Thanks for your patience!
Peter2 wrote:I found this old thread from 24.12.2011 again (by incident ..), added it to my new machine (and modified it for my own site too :wink: )
cadraktiv gmbh: Search results for “xnview8)

Re: Forum search function bug?

Posted: Thu Feb 05, 2015 6:00 pm
by XnTriq
I finally came around to adding OpenSearch support to the forum.
You can install the plug-in through your browser's auto-discovery or the “Add plug-in” button on the advanced search page.

Re: Forum search function bug?

Posted: Wed Mar 18, 2015 12:21 pm
by omniplex
XnTriq wrote:Chrome Adds OpenSearch Plugins Automatically
Yes, but it's not in a good usable state after the addition. For some fine tuning open chrome://settings/searchEngines manually or navigate to it in the Chrome settings. The search engines page consists of your Default search settings at the top, and recently added Other search engines. Step by step suggestion, sorry, I don't grok how the forum "list" features work.

1: Make a (mental) note of your standard search engine, that's the Default entry in the Default search settings.
2: Find the XnView Forum (Google) entry near the bottom, it's sorted alphabetically, a major advantage for X.
3: Click on Make Default, this clobbers your default noted in step 1, but also moves the forum search to the Default search settings.
4: Close the search settings to save the result of step 3, and open Manage search engines again.
5: Click on Make Default for your old Default noted in step 1. Repeat step 4 (close + reopen) to check that your old search is as it should be, with a new shiny XnView Forum (Google) entry in the Default search settings.
6: Optional, file a bug report at the Chromium project, and ask them what they were smoking, and where you can get it cheap.
7: Click on the newsgroup.xnview.com alias, it's the 2nd part of the new entry, and pick a shorter alias, e.g., xn or xnview.
8: Optional, close and reopen again to save the shorter alias, and tweak the search query in the 3rd part of the new entry as you like, e.g., add hl=en&safe=off&nord=1& immediately before q=%s at its end.
9: Click done. Now if you want to search the forum just type xn or xnview, Space-key, your query, Enter-key in the "Omnibox" (formerly known as address bar or location bar.) 8)

Code: Select all

http://www.google.com/search?sitesearch=newsgroup.xnview.com&hl=en&safe=off&nord=1&q=%s
Of course you can simply remove the newsgroup. part for a site search covering everything on xnview.com, as far as GoogleBot visited it, and is allowed to index it.

Re: Forum search function bug?

Posted: Wed Mar 18, 2015 4:30 pm
by XnTriq
omniplex wrote:Yes, but it's not in a good usable state after the addition.

[…]

7: Click on the newsgroup.xnview.com alias, it's the 2nd part of the new entry, and pick a shorter alias, e.g., xn or xnview.

[…]

9: Click done. Now if you want to search the forum just type xn or xnview, Space-key, your query, Enter-key in the "Omnibox" (formerly known as address bar or location bar.)
That's why I listed the video tutorial courtesy of GVSU Libraries (0:46) in my previous post. ;-)
omniplex wrote:Of course you can simply remove the newsgroup. part for a site search covering everything on xnview.com, as far as GoogleBot visited it, and is allowed to index it.
FYI: No exclusions specified in robots.txt
XnTriq wrote:Sorry for the late response. I'm subscribed to this topic, but for some reason I didn't get any reply notifications. :?
There seems to be a limit in phpBB regarding the number of topics you can subscribe to. Although the checkbox for “Notify me when a reply is posted” is activated, I didn't get an e-mail for this latest response either.