XnRetro 1.26: Light effect don't work

More Multi Platform Tools - Windows, MacOSX, Linux
scx
Posts: 10
Joined: Sun Mar 03, 2019 3:59 pm

Re: XnRetro 1.26: Light effect don't work

Post by scx » Sat Mar 09, 2019 7:51 pm

optom wrote:
Tue Apr 30, 2013 5:56 pm
Hello!

I've just downloaded XnRetro (1.26) for Linux. First of all: I'm using the 32bit version on my Ubuntu 13.04 64bit machine. Unfortunately, your link to the 64bit version is broken.

The main problem: Light effects don't work. Doesn't matter which one I choose, they don't apply to the image. Also, there are no light effect previews in the bottom bar, see screenshot:

Image

Everything else seems to work fine :)
I believe that this problem is related to the bundled Qt4 libs.

Try to enable Qt debug messages:

Code: Select all

export QT_DEBUG_PLUGINS=1 
export QML_IMPORT_TRACE=1
and then start the app:

Code: Select all

./xnretro.sh
You should see something like this on the console:

Code: Select all

"The plugin '/app/XnRetro/lib/imageformats/libqgif.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqico.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqjpeg.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqmng.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqsvg.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqtga.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
"The plugin '/app/XnRetro/lib/imageformats/libqtiff.so' uses incompatible Qt library. Expected build key "i386 linux g++-4 full-config", got "x86_64 linux g++-4 full-config""
It seems that this is an old Qt4 issue.
https://bugreports.qt.io/browse/QTBUG-33102
Build problem & won't fix for Qt 4. It's been like that since 2005, when Qt 4.0 was released.

When compiling Qt 4 on a 64-bit system, you should always run:

Code: Select all

i386 configure -platform linux-g++-32
This is fixed in Qt 5 by a complete rewrite of the Qt arch-specific code.
Anyway, I was able to fix it in my flatpak package by rebuilding Qt4 on my own.

More info about my flatpak packages:
viewtopic.php?f=79&t=33329&&start=0&p=155029#p155029
viewtopic.php?f=79&t=33329&&start=15&p=155203#p155203

Post Reply