Page 1 of 1

XnRetro

Posted: Sun Nov 26, 2017 11:23 am
by avpco
Hello.

I can't start ./xnretro.sh because I got error meggage: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory

What program I need to install for start XnRetro (Ubuntu 16.04 x64) ?
Thank's in advance!

Re: XnRetro

Posted: Sun Nov 26, 2017 2:57 pm
by xnview
do you have installed x86 libraries?

Re: XnRetro

Posted: Sun Nov 26, 2017 6:30 pm
by avpco
How can I know this? I'm a beginner user :(

Re: XnRetro

Posted: Mon Nov 27, 2017 7:44 am
by xnview
please check this post

Re: XnRetro

Posted: Mon Nov 27, 2017 9:36 am
by avpco
Thanks, Pierre.
I'll try it at everning.

Re: XnRetro

Posted: Mon Nov 27, 2017 5:17 pm
by avpco
these packages are already installed.
where else can the error be contained?

Re: XnRetro

Posted: Sat Mar 31, 2018 11:35 am
by dannyw
I was able to get it working on ubuntu 16.04 by doing this:

Code: Select all

sudo apt install libglib2.0-0:i386
sudo apt install libgstreamer-plugins:i386 # <-- Not sure if this one is required
sudo apt install gstreamer0.10-plugins-base:i386

Re: XnRetro

Posted: Sat Mar 09, 2019 7:31 pm
by scx
avpco wrote:
Sun Nov 26, 2017 11:23 am
Hello.

I can't start ./xnretro.sh because I got error meggage: error while loading shared libraries: libgio-2.0.so.0: cannot open shared object file: No such file or directory

What program I need to install for start XnRetro (Ubuntu 16.04 x64) ?
Thank's in advance!
I have created flatpak packages for XnView MP, XnConvert, XnSketch and XnRetro.
viewtopic.php?f=79&t=33329&&start=0&p=155029#p155029
viewtopic.php?f=79&t=33329&&start=15&p=155203#p155203

All of these packages should appear on Flathub soon.