XnView MP 0.84 & 0.85 don't work on Linux Mint

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

xdfv
Posts: 5
Joined: Fri Apr 07, 2017 7:07 pm

XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xdfv » Fri Apr 07, 2017 7:22 pm

Hi,

I‘m using LinuxMint 18.1 Mate 32 with all updates.
I’ve installed XnView 0.84 but the program does not start.
Later I saw, there is the new version, 0.85.
I’ve installed it, but the same problem, the program does not work.

If I click right mouse button on a file (e.g. .gif) and select from menu “open with XnView”, then on the task bar the new icon “opening ...” will be displayed (for about 12-15 s) and then will be closed and XnView is not started.
I’ve started then on the same computer the LM18.1 live (from iso file), then installed 0.85, no success.

I’ve started then the same LM18.1 live on one another computer, then installed from the same file the 0.85 version, it worked perfect.
It looks like the problem is the hardware compatibility of the first computer.

On the forum here “General Support” I found this:
http://newsgroup.xnview.com/viewtopic.php?f=82&t=34695
After update from 0.83 to 0.84 program does not work anymore.

I would like to test the version 0.83 to see, if I have the same problem.
But I cannot find download of the old file XnViewMP-linux.deb (Linux DEB 32-bit 0.83).

Is it possible to download it?
If yes, from where?

Regards
xdfv

cday
XnThusiast
Posts: 1534
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: XnView MP 0.84 & 0.85 does not work

Postby cday » Fri Apr 07, 2017 7:29 pm

Previous versions of XnView software can be downloaded from this well-hidden link, so you should find it there if you scroll down... :D

User avatar
xnview
Author of XnView
Posts: 27910
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.84 & 0.85 does not work

Postby xnview » Sat Apr 08, 2017 8:03 am

For 0.83 do you have used this DEB file or this one
Pierre.

xdfv
Posts: 5
Joined: Fri Apr 07, 2017 7:07 pm

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xdfv » Sat Apr 08, 2017 11:14 am

Hi,
tnx for answers.

In the last answer there is written I have to use the included link for 0.83 download the needed file.
But the downloaded file is 0.85 version and not 0.83, and of course does not work.

The second link shows the file: XnViewMP-linux-RH.tgz
What mean the RH, maybe RedHat?
If yes, then it cannot work.
The LinuxMint is based on Ubuntu, and Ubuntu on Debian.
In the file XnViewMP-linux-RH.tgz from the link the sub folder lib is not included.
The sub folder lib is included XnViewMP-085-linux.tgz, but after unpacking the program does not work as well.

cday wrote the link to older versions, tnx for this.
Having this I was able to test another versions.
This are my findings.
XnViewMP-050-linux.deb after installation works well. This is the first deb packet in the download folder.
XnViewMP-060-linux.deb after installation works well.
XnViewMP-070-linux.deb after installation works well.
XnViewMP-072-linux.deb after installation works well.

But beginning with the version XnViewMP-075-linux.deb the program after installation does not work.
By all versions is the same, after installation, right click on a picture, select "open with XnView", on the task bar the new icon „openning...“ will be displayed and after 12-15 will be closed.

I do not know if the problem have to be investigated as the version 075 of the program was given to use in 22-Sep-2015 and until now nobody reported this problem.
Would you like to have more details, I can make tries.

Regards
xdfv

User avatar
xnview
Author of XnView
Posts: 27910
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xnview » Sat Apr 08, 2017 11:21 am

if you start xnview in a terminal, which message do you have?
I've tried on a clean Mint 18, and no problem to start it
Pierre.

xdfv
Posts: 5
Joined: Fri Apr 07, 2017 7:07 pm

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xdfv » Sat Apr 08, 2017 5:52 pm

I do not have any problem on the notebook HP6570b with LM18.1 and XnViewMP0.85 too.

I have the described problem on an older ASUS desktop computer.

In both cases I am using the same USB stick with LM18.1.iso on it.
After LM18.1 is started I am installing the XnViewMP-085-linux.deb

Then on the noteboook HP6570b
- I go to Graphics/XnView Multi Platform, -- program will be started
- I click on a picture right mouse button/Open With/XnView Multi Platform – program will be started, picture loaded
- in terminal, in /usr/bin command ./xnview – program will be started

But on the ASUS computer, the same USB stick, the same LM18.1.iso file and the same XnViewMP-085-linux.deb file,
during the installation the Package Installer says:
All dependencies are satisfied
and then
- I go to Graphics -- XnView Multi Platform is not listed there
- I click on a picture right mouse button/Open With/XnView Multi Platform – as described, on the task bar new icon „opening...“ and after 12-15 s the icon disappeare, program not started
- in terminal, in /usr/bin command ./xnview – Illegal instruction

On the same Asus, on the same way installed XnViewMP-072-linux.deb or any another deb packets before 072 are working well.

xdfv

User avatar
xnview
Author of XnView
Posts: 27910
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xnview » Sat Apr 08, 2017 8:41 pm

xdfv wrote:- in terminal, in /usr/bin command ./xnview – Illegal instruction

Same with 0.85 tgz?
Pierre.

xdfv
Posts: 5
Joined: Fri Apr 07, 2017 7:07 pm

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xdfv » Sun Apr 09, 2017 10:19 am

Same with 0.85 tgz?


No, XnViewMP-085-linux.tgz as well as in XnViewMP-075-linux.tgz

./XnView: error while loading shared libraries: libQt5MultimediaWidgets.so.5: cannot open shared object file: No such file or directory

User avatar
xnview
Author of XnView
Posts: 27910
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xnview » Sun Apr 09, 2017 11:27 am

xdfv wrote:
Same with 0.85 tgz?

No, XnViewMP-085-linux.tgz as well as in XnViewMP-075-linux.tgz

you have 'Illegal instruction' with tgz too?

./XnView: error while loading shared libraries: libQt5MultimediaWidgets.so.5: cannot open shared object file: No such file or directory

yes it's normal, you need to start by xnview.sh
Pierre.

xdfv
Posts: 5
Joined: Fri Apr 07, 2017 7:07 pm

Re: XnView MP 0.84 & 0.85 don't work on Linux Mint

Postby xdfv » Sun Apr 09, 2017 1:33 pm

XnViewMP-085-linux.tgz

./xnview.sh

Illegal instruction


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 5 guests