Intermittent Timestamp corruption when moving files

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Intermittent Timestamp corruption when moving files

Postby bobbozzo » Sun May 28, 2017 8:16 pm

Hi,
I'm currently using 0.86 64-bit, but this has been going on for awhile.

When I drag files or folders in XnView MP on Windows 8.1 to a different folder, frequently some of the files lose their timestamps.

SOMETIMES, 1 or more of the modified files will have timestamps with dates of 1601-01-01 (see screenshots). Note this is in the Windows NTFS file properties, not the EXIF data.
Because of this, programs have trouble with the files (RawTherapee won't open the files, XnViewMP won't show properties or build a new thumbnail, ...)

Thanks
Attachments
105-explorer.png
file properties.png
file properties.png (24.2 KiB) Viewed 818 times

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Sun May 28, 2017 8:33 pm

I have the "Keep original date/time" options all set.

When this happens, the date is always 1/1/1601, but the times are random but all the same for the affected set of files.

i.e. the last set this happened to, all files have the timestamp of 1/1/1601 08:49,
but another set will have the same date but a different time.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Wed May 31, 2017 9:54 pm

Any ideas or things I could try?

User avatar
xnview
Author of XnView
Posts: 28073
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Intermittent Timestamp corruption when moving files

Postby xnview » Wed Jun 07, 2017 7:43 am

From windows explorer into XnViewMP browser?
Pierre.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Thu Jun 29, 2017 9:14 pm

Hi Pierre,

I'm dragging files/folders around in XnView, not Windows explorer.

Thanks

User avatar
xnview
Author of XnView
Posts: 28073
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Intermittent Timestamp corruption when moving files

Postby xnview » Fri Jun 30, 2017 11:41 am

From thumbnail view, into thumbnail view? you are able to reproduce it often?
Pierre.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Fri Jun 30, 2017 7:04 pm

Yes, selecting one or more thumnails, and either hitting CTRL-X, and CTRL-V in another folder, or using the mouse to drag them.

It happens fairly often, affecting one or more of the files at a time.

thanks

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Fri Jun 30, 2017 7:07 pm

BTW, someone on another forum said AntiVirus sw may be a factor; I use Avast.

But it doesn't happen with other programs; I move files around with TotalCommander all the time and it's never happened.

User avatar
xnview
Author of XnView
Posts: 28073
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Intermittent Timestamp corruption when moving files

Postby xnview » Sat Jul 01, 2017 11:10 am

bobbozzo wrote:Yes, selecting one or more thumnails, and either hitting CTRL-X, and CTRL-V in another folder, or using the mouse to drag them.

It happens fairly often, affecting one or more of the files at a time.

All file formats?
Pierre.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Sat Jul 01, 2017 9:25 pm

Definitely .ORF files, not sure about JPG.

User avatar
xnview
Author of XnView
Posts: 28073
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Intermittent Timestamp corruption when moving files

Postby xnview » Sat Jul 08, 2017 1:21 pm

bobbozzo wrote:Definitely .ORF files, not sure about JPG.

could you try with other formats?
Pierre.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Sat Oct 21, 2017 6:16 am

Hi,
Using MP 0.87 64-bit, I just dragged (from the right preview pane) 10 folders and 1 file to another folder (on the left tree pane) and the timestamps were corrupted on 396 files (out of 434).

The filetypes vary, including ORF, .pp3 (RawTherapee edits), .jpg, & .txt.

This time, the files were moved from one partition to another, but both partitions are mounted under the same drive letter.
i.e. the source partition is mounted as
P:\incoming
and the destination is mounted as
P:\
Using Windows Disk Management options to mount a partition in a folder.

I don't know if that's related to the problem but it's certainly possible.

bobbozzo
Posts: 18
Joined: Sat Jun 16, 2012 7:25 am

Re: Intermittent Timestamp corruption when moving files

Postby bobbozzo » Sat Oct 21, 2017 8:01 am

More info:
1. It doesn't seem to happen on Copy (Ctrl-C Ctrl-V), but it pretty consistently happens on Move (drag or Ctrl-X - Ctrl-V) to the other partition.
(this does not happen with Windows Explorer or other programs)

2. disabling my antivirus doesn't help

3. moving files to another drive letter shows the same problem, e.g. from
P:\incoming to T:\temp
or
T:\temp to P:\temp
or
T:\temp to V:\temp (note T and V have no extra mounts like P:\incoming does)

(this does not happen with Windows Explorer or other programs)


SO, it seems to happen whenever MOVING files from one partition to another.
The good news is Copy seems safe, so I guess I can Copy and then Delete, if I can remember that.

I'm still on Win 8.1, 64-bit, btw, and all drives are NTFS, no compression.


Return to “MP - General Support”

Who is online

Users browsing this forum: sfg and 1 guest