Windows XP - Entry Point not found

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
MarkUK
Posts: 2
Joined: Mon Jun 19, 2017 8:00 am

Windows XP - Entry Point not found

Post by MarkUK » Mon Jun 19, 2017 8:15 am

Hello
I have just updated to version 0.86 and am getting an error message when I try to open.

The procedure entry point GetUserPreferredUILanguages could not be located in the dynamic link library Kernel32.dll and XnView will not open.

Tried a complete uninstall and reinstalled but still cannot open. Any ideas?
I am using XP professional SP3... not had any problems before and have been using for many years.

cday
XnThusiast
Posts: 1816
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Entry Point not found

Post by cday » Mon Jun 19, 2017 8:23 am

This previous post may be relevant:

XnView MP on Windows XP: InitializeCriticalSectionEx

... however, I believe that Support for Windows XP was recently discontinued (for, ultimately, a good reason...) so a slightly earlier version of 'MP may be the last version you can use... :(

MarkUK
Posts: 2
Joined: Mon Jun 19, 2017 8:00 am

Re: Entry Point not found

Post by MarkUK » Mon Jun 19, 2017 8:30 pm

cday wrote: ... however, I believe that Support for Windows XP was recently discontinued (for, ultimately, a good reason...) so a slightly earlier version of 'MP may be the last version you can use... :(
Thanks.. Been there and not really helpful. Have reverted to XnView at the moment but I should have the previous version hidden away somewhere and will try that. At the moment I am sticking with XP until I have the time to build myself a new pc... professional version and, despite what is said, Microsoft are still releasing regualar security updates.

Cheers

RxoJHYsDZT
Posts: 1
Joined: Tue Jul 04, 2017 7:13 am

Windows XP - Entry Point not found

Post by RxoJHYsDZT » Tue Jul 04, 2017 7:32 am

MarkUK wrote:I have just updated to version 0.86 and am getting an error message when I try to open.

The procedure entry point GetUserPreferredUILanguages could not be located in the dynamic link library Kernel32.dll and XnView will not open.
I have the same problem.
Would you please fix it?

Do not suggest installing a damn Windows Vista, 7, 8, 10!!!


Thank you.

bdragon
Posts: 107
Joined: Mon May 01, 2017 8:06 am

Re: Windows XP - Entry Point not found

Post by bdragon » Tue Jul 04, 2017 8:12 am

I understand people still cling on XP for very good and undertandable reasons (like having to redesign industrial robot software or because you live in a country where the only windows version sold is crippled or because you live in a country where getting the latest windows version costs as much as a month and an half if not two of decent work).

However...

...If you cling to XP just because "i like it better"... It is time to move on. It is highly unsafe to keep XP and it becomes unsafer by the minute as more and more internet security companies leave it.

cday
XnThusiast
Posts: 1816
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Entry Point not found

Post by cday » Tue Jul 04, 2017 1:57 pm

cday wrote:Support for Windows XP and Vista was recently discontinued (for, ultimately, a good reason...) so a slightly earlier version of 'MP will be the last version you can use... :(
You can download previous versions from this link. :D

It would be helpful if you could confirm which version was the last to run on XP :?:

adriespo
Posts: 1
Joined: Tue Oct 03, 2017 12:30 pm

Re: Windows XP - Entry Point not found

Post by adriespo » Tue Oct 03, 2017 12:38 pm

cday wrote:It would be helpful if you could confirm which version was the last to run on XP :?:
I use XnViewMP Version 0.84 x32 (Jan 12 2017) on XP Pro 2002 SP3. Note that this version still get an error a the start up using the function InitializeCriticalSectionEx of the file kernel32.dll but it does not crash... It continues and run very well.

jugulator
Posts: 1
Joined: Tue Dec 12, 2017 4:39 pm

Re: Windows XP - Entry Point not found

Post by jugulator » Tue Dec 12, 2017 4:58 pm

Using XnViewMP v0.84 x32 on XP Pro 2002 SP3 works fine. (Last version that works on WinXP)

To prevent the "Entry Point no found..." warning at program startup, delete or rename webp.dll in the plugins directory (I just renamed it to webp.dll-disabled).

To regain some of that format functionality using an older XP compatible version of the dll (that doesn't fully support current WEBP formats), download an older version of the dll, extract it from the zip archive, and put it in the plugins directory. (I don't use or need WEBP, so am fine with this workaround) http://www.xnview.com/download/plugins/webp.zip

See this thread: viewtopic.php?t=32900

Post Reply