Thumbs not caching?

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

3x5
Posts: 28
Joined: Fri Feb 26, 2016 8:58 pm

Thumbs not caching?

Postby 3x5 » Wed Aug 02, 2017 8:54 pm

I had the idea that XnView has a database where it saves thumbnails. However, I have some directories mapped to a remote drive on my home network, and I have noticed that every time I revisit a directory after restarting XnView, the program slowly renders each thumbnail, leading me to assume it's creating new thumbs from the files themselves, or trying to read an embedded thumnail.

In settings, I have 'Use embedded thumbnail' unchecked, although 'Create from original image if embedded thumbnail is smaller...' is checked. Also, 'Create thumbnails for whole folder' is checked.

3x5
Posts: 28
Joined: Fri Feb 26, 2016 8:58 pm

Re: Thumbs not caching?

Postby 3x5 » Thu Aug 03, 2017 3:03 am

I think I may have found the answer to this. When I browse by folder, the thumbs load slowly, but if I browse by category, or some other criterion stored in the db, the thumbs load instantly.

User avatar
xnview
Author of XnView
Posts: 28043
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbs not caching?

Postby xnview » Thu Aug 03, 2017 2:56 pm

do you use a base path?
Pierre.

3x5
Posts: 28
Joined: Fri Feb 26, 2016 8:58 pm

Re: Thumbs not caching?

Postby 3x5 » Wed Aug 16, 2017 9:23 pm

Yes, I do use a base path.

User avatar
xnview
Author of XnView
Posts: 28043
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbs not caching?

Postby xnview » Sun Aug 20, 2017 3:03 pm

do you have the problem with a no networked folder but not with your base path?
Pierre.


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 5 guests