Page 1 of 1

XnViewMP very slow since last update

Posted: Tue Sep 12, 2017 2:38 pm
by phorh
Hello,

First, I absolutely love XnViewMP.
I just updated to the last version but now it is very very slow compared to what it was.

If I open a folder, click on a photo to see a fullsize preview, navigating previous / next is slow.

Am I doing something wrong?

Thanks.

Re: XnViewMP very slow since last update

Posted: Tue Sep 12, 2017 7:02 pm
by xnview
on Windows? What is slow, the next/previous?

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 5:24 am
by phorh
Hey Pierre,

on Mac. Yes the previous / slow is slow.
I went back to the previous version for now.

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 6:45 am
by cch44
Hey,
on Ubuntu Mate, very slow, 16,04

slow to read repertories, preview ....

Thanks

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 7:32 am
by xnview
cch44 wrote:slow to read repertories, preview ....

In browser, if you open a folder, it's not the same speed between 0.86 and 0.87?

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 7:33 am
by xnview
phorh wrote:on Mac. Yes the previous / slow is slow.
I went back to the previous version for now.

And the creation of thumbnails? With previous version no more delay?
Do you use Read ahead & Cache behind?

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 7:49 am
by phorh
xnview wrote:And the creation of thumbnails? With previous version no more delay?


I didn't notice any slowness during creation of thumbnails.
To me it only appears to be slow when double clicking an image, then navigating with the left / right arrows.

No problem at all now that I switched back to the previous release.

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 8:21 am
by xnview
phorh wrote:
xnview wrote:And the creation of thumbnails? With previous version no more delay?

I didn't notice any slowness during creation of thumbnails.
To me it only appears to be slow when double clicking an image, then navigating with the left / right arrows.

If you open XnView MP in browser mode, open a picture, and use next/previous, same problem?
Do you use Read ahead & Cache behind?

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 1:56 pm
by phorh
xnview wrote:If you open XnView MP in browser mode, open a picture, and use next/previous, same problem?
Do you use Read ahead & Cache behind?


That's already what I'm doing to have the problem. Browser mode, open a picture and next/previous.

I don't know what you mean by "Read ahead & Cache behind". I haven't set anything specific after install the software.

Re: XnViewMP very slow since last update

Posted: Wed Sep 13, 2017 2:08 pm
by xnview
phorh wrote:
xnview wrote:If you open XnView MP in browser mode, open a picture, and use next/previous, same problem?
Do you use Read ahead & Cache behind?


That's already what I'm doing to have the problem. Browser mode, open a picture and next/previous.
I don't know what you mean by "Read ahead & Cache behind". I haven't set anything specific after install the software.

could you send me your xnview.ini? which format of picture? which size (pixels)?

Re: XnViewMP very slow since last update

Posted: Fri Sep 15, 2017 1:20 pm
by xnview
phorh wrote:I just updated to the last version but now it is very very slow compared to what it was.

do you have some news?