UTF-8 issue under Mint 18.2

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

monitor
Posts: 35
Joined: Thu Apr 06, 2017 9:29 pm

UTF-8 issue under Mint 18.2

Postby monitor » Fri Oct 20, 2017 9:28 pm

As I am working with Gramps and image metadata a fair bit, I have just installed XnViewMP 0.86 under Mint 18.2 and have come across a curious issue, possibly related to UTF-8 & German Umlauts, perhaps not.
I am attaching two screenshot and basically the issue is that, under Linux, in the categories pane, a 'ö' character in a name does not display properly, but a ' ß' does.
While under Windows, viewing the same file, in the same metadata item, the name shows as expected.
I realize that the two copies of XnViewMP do not have the same set of categories, as I have not transferred those, but, assuming the less complete set in the Linux installation all came from the image metadata, I am puzzled why they might differ for the one item I have found at this time
Attachments
XnViewMPWindows-Umlaut.jpg
XnViewMP-Mint-Umlaut.jpg

User avatar
xnview
Author of XnView
Posts: 28299
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: UTF-8 issue under Mint 18.2

Postby xnview » Sun Oct 22, 2017 8:09 am

if categories are from IPTC, please check Settings>Metadata>Encoding
Pierre.

monitor
Posts: 35
Joined: Thu Apr 06, 2017 9:29 pm

Re: UTF-8 issue under Mint 18.2

Postby monitor » Mon Oct 23, 2017 1:13 am

It was set to Locale for both Win 10 & Mint.

But ... after doing more low level testing of the actual image files on the two machines, I have to check out some other issues with the software that backed up these files and that which unpacked them.
For now at least, there is a difference in the files and I no longer think it is a problem with XnViewMP :D


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 2 guests