Missing categories and ratings

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
akom
Posts: 5
Joined: Tue Oct 10, 2017 11:55 am

Missing categories and ratings

Post by akom » Thu Dec 21, 2017 9:52 pm

Hallo!
I'm using XnviewMP 0.88 / Ubuntu.
The Tab Kategorien-Filter / Category-Filters shows the five rating-stars, the colour-tags and then under Spezielle Einträge / special entries a submenue categories, but there are no categories listed. The context-menu shows 'new category', but a left-click on it does not produce any kind of opportunity to make an entry.
When giving a rating e.g. a '3 stars' / green to one or more fotos, these ratings will have been disappeard after changing the view to another folder and then return .


Thanks for any advice.

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing categories and ratings

Post by xnview » Fri Dec 22, 2017 1:01 pm

could you post a screenshot?
Pierre.

akom
Posts: 5
Joined: Tue Oct 10, 2017 11:55 am

Re: Missing categories and ratings

Post by akom » Fri Dec 22, 2017 8:45 pm

Here is a screenshot wenn trying to add a categorie. Meanwhile I read som more posts about categories and found something about the caegories.db or category.db On my computer a categories.db does not exist, neither in the xnview folder nor elswhere. How to get one?

Thank you, Albert
Attachments
Bildschirmfoto vom 2017-12-22 21-36-47.png

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing categories and ratings

Post by xnview » Sun Dec 24, 2017 2:20 pm

there is a problem, you should have some default categories. Please try to remove xnview.db?
Pierre.

akom
Posts: 5
Joined: Tue Oct 10, 2017 11:55 am

Re: Missing categories and ratings

Post by akom » Wed Dec 27, 2017 8:04 pm

Merci Pierre!

I 'removed' Xnview.db by renaming it. After start of the program there was a new one in ~/.config/xnviewmp. An sqlite-browser showed an empty database, I attach a screenshot.
Would'nt it be the easiest solution to make a new installion. There is nothing to lose, is'nt it?

Best wishes for the new year! Albert
Attachments
Screenshot Xnview.db2017-12-27.png

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing categories and ratings

Post by xnview » Sat Dec 30, 2017 2:27 pm

it seems that XnView can't correctly create the database. Thumb.db is created too?
Pierre.

Post Reply