GPS tab is empty

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Alexey87
Posts: 2
Joined: Thu Jan 04, 2018 11:20 am

GPS tab is empty

Post by Alexey87 » Thu Jan 04, 2018 11:49 am

Hi all,

I use XnViewMP 0.88 64bits on Debian GNU/Linux 9.3.

When I'm in Browser or in Fullscreen modes I can navigate to GPS tab (next to ExifTool) but there is nothing in the opened GPS tab. I can perform left-click on it and see 'Reload' pop-up message. That's all. Note that both 'Open GPS location in GeoHack...' and 'Open GPS location in Google Earth...' tools work for me.

I didn't use GPS feature for few months. But I remembered that it worked fine.

What I tried:
  • different versions (from 0.84)
    to remove .config/xnviewmp/ in my home directory
    checked that XnViewMP isn't blacklisted in my firewall

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: GPS tab is empty

Post by xnview » Sat Jan 06, 2018 11:17 am

no map?
could you try to start it from a console, and see if you have message when you click on GPS tab?
Pierre.

Alexey87
Posts: 2
Joined: Thu Jan 04, 2018 11:20 am

Re: GPS tab is empty

Post by Alexey87 » Sat Jan 06, 2018 1:28 pm

Hi Pierre,

After your advice I started xnviewmp from a console and saw

Code: Select all

qt.network.ssl: Incompatible version of OpenSSL
message. I use libssl 1.1.0 (which is current version of the library on Debian Stretch). So I installed a transition package libssl1.0-dev and missing map on GPS tab comes back!

Thank you very much!

User avatar
JoWa
Posts: 3
Joined: Sun Apr 29, 2018 8:40 am

Re: GPS tab is empty

Post by JoWa » Sun Apr 29, 2018 8:44 am

Hi.

It is empty also in XnView MP 0.90 64bits on Ubuntu 18.04.

From Terminal:

Code: Select all

QObject::connect: No such signal GPSMapWidget::reloadMap()
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
qt.network.ssl: QSslSocket: cannot resolve sk_new_null
qt.network.ssl: QSslSocket: cannot resolve sk_push
qt.network.ssl: QSslSocket: cannot resolve sk_free
qt.network.ssl: QSslSocket: cannot resolve sk_num
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
qt.network.ssl: QSslSocket: cannot resolve sk_value
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
qt.network.ssl: QSslSocket: cannot resolve SSLeay
qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
qt.network.ssl: QSslSocket: cannot call unresolved function SSLeay
qt.network.ssl: Incompatible version of OpenSSL
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
Thanks. :)

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: GPS tab is empty

Post by xnview » Sun Apr 29, 2018 11:52 am

the problem comes from openssl (v1 is needed)
Pierre.

gagala
Posts: 7
Joined: Sat Feb 28, 2015 9:01 am

Re: GPS tab is empty

Post by gagala » Sat Sep 29, 2018 2:53 am

xnview wrote:
Sun Apr 29, 2018 11:52 am
the problem comes from openssl (v1 is needed)
Will you update MP for openssl v1.1?
Using Xubuntu 18.04 with openssl v1.1.0 and tried to install v1.0 secondarily, but it didn't work.

Post Reply