Page 1 of 1

Supported Platforms

Posted: Sun Jan 21, 2018 3:36 pm
by xnview
Windows 7, 8, 10 & + : XnConvert 1.76 & XnView MP 0.89
Windows XP & Vista: XnConvert 1.74 & XnView MP 0.84

Mac OS 10.10 & + : XnConvert 1.76 & XnView MP 0.89
Mac OS 10.9 : XnConvert 1.74 & XnView MP 0.87
Mac OS 10.7-10.8 : XnConvert 1.73 & XnView MP 0.83
Mac OS 10.6 : XnConvert 1.70 & XnView MP 0.64 (i think)

Oldest versions can be found here

Re: Supported Platforms

Posted: Sun Jan 21, 2018 7:30 pm
by XnTriq
Hi Pierre (-:

XnConvert v1.75 throws an error on XP SP3…
xnconvert.exe (Entry Point Not Found) wrote:The procedure entry point GetUserPreferredUILanguages could not be located in the dynamic link library KERNEL32.dll.
… and refuses to run. Version 1.74 also complains at startup, …
xnconvert.exe (Entry Point Not Found) wrote:The procedure entry point InitializeCriticalSectionEx could not be located in the dynamic link library KERNEL32.dll.
… but this error can be resolved by deleting (or replacing) \plugins\webp.dll.

Related: xnconvert.exe from zip file will not run

Re: Supported Platforms

Posted: Sun Feb 25, 2018 9:00 am
by Roger27
Thank you a lot Pierre.

Re: Supported Platforms

Posted: Tue Dec 11, 2018 3:49 pm
by isidroco
Info about supported platforms should be stated on main page before DL. Link to last XP version would be useful too.

Re: Supported Platforms

Posted: Tue Feb 05, 2019 4:15 am
by XnTriq
Qt Forum: Qt 5.6 doesn't compatible with Windows XP
if you try build Qt again, but this time with DirectWrite disabled (as in 5.5) then you should be fine in Windows XP:

Code: Select all

configure -debug-and-release -opensource -confirm-license -mp -icu -openssl -nomake examples -nomake tests -target xp -skip qtwebkit -no-directwrite

Qt Documentation: Targeting XP with Visual Studio 2012 and later
Visual Studio 2012 and later do not support building for Windows XP out of the box. However, support for targeting XP was added in an update of Visual Studio 2012. This works also with Visual Studio 2013.

Re: Supported Platforms

Posted: Thu Feb 21, 2019 8:01 am
by labuzhskiy
xnview wrote:
Sun Jan 21, 2018 3:36 pm
Windows 7, 8, 10 & + : XnConvert 1.76 & XnView MP 0.89
Windows XP & Vista: XnConvert 1.74 & XnView MP 0.84

Mac OS 10.10 & + : XnConvert 1.76 & XnView MP 0.89
Mac OS 10.9 : XnConvert 1.74 & XnView MP 0.87
Mac OS 10.7-10.8 : XnConvert 1.73 & XnView MP 0.83
Mac OS 10.6 : XnConvert 1.70 & XnView MP 0.64 (i think)

Oldest versions can be found here
Hello!
May we hope that the version of XnViewMP for arm64 platform (as for an example of NanoPC-T4_Ubuntu-LXDE will be released: arm64 https://forums.linuxmint.com/viewtopic. ... 5&t=287738)? :?:

Re: Supported Platforms

Posted: Thu Feb 21, 2019 2:07 pm
by xnview
labuzhskiy wrote:
Thu Feb 21, 2019 8:01 am
May we hope that the version of XnViewMP for arm64 platform (as for an example of NanoPC-T4_Ubuntu-LXDE will be released: arm64 https://forums.linuxmint.com/viewtopic. ... 5&t=287738)? :?:
you have the 0.92 in ARM version here

Re: Supported Platforms

Posted: Wed Feb 27, 2019 4:44 am
by labuzhskiy
xnview wrote:
Thu Feb 21, 2019 2:07 pm
labuzhskiy wrote:
Thu Feb 21, 2019 8:01 am
May we hope that the version of XnViewMP for arm64 platform (as for an example of NanoPC-T4_Ubuntu-LXDE will be released: arm64 https://forums.linuxmint.com/viewtopic. ... 5&t=287738)? :?:
you have the 0.92 in ARM version here
I'm sorry, but we can't use it in the Ubuntu Bionic; Problem of not resolved dependences. At dependences there are Debian libs which are not recommended for installation in Ubuntu-Bionic:arm64. :bug:

Re: Supported Platforms

Posted: Tue Sep 17, 2019 5:56 am
by los974
Hi,
the link to the old versions repository seems to be currently broken: I always get a "Forbidden" page. Could it be possible to fix this error?

I am interested in downloading the last version of XnView MP that works on MacOSX 10.8 Mountain Lion.

Greetings from Reunion Island,

Los

Re: Supported Platforms

Posted: Tue Sep 17, 2019 8:58 am
by xnview
los974 wrote:
Tue Sep 17, 2019 5:56 am
the link to the old versions repository seems to be currently broken: I always get a "Forbidden" page. Could it be possible to fix this error?

I am interested in downloading the last version of XnView MP that works on MacOSX 10.8 Mountain Lion.
it's fixed