Linux - Main window moves with adjustment window

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
hako
Posts: 3
Joined: Tue May 29, 2018 2:06 pm

Linux - Main window moves with adjustment window

Post by hako » Tue May 29, 2018 3:15 pm

I am using v0.89 appimage on Ubuntu 18.04 64 bit. When I want to adjust a picture (etc via image > adjust > levels), a window opens where I can change the settings. If I move this window, the underlying picture window also moves. The adjustment window hides the picture window making the adjustment a blind flight.
In an earlier version the same thing happened, but another previous version worked correctly.
Unfortunately, I cannot remember which version was ok.

N.B.: Version 0.90 does not let me access files on another drive (in Linux mounted via /mnt/dir), only the home folder can be used. Also a problem that occurred on earlier versions, but not in 0.89.

So, which version should I try to get a usable xnviewmp?

User avatar
xnview
Author of XnView
Posts: 29869
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux - Main window moves with adjustment window

Post by xnview » Tue May 29, 2018 6:24 pm

hako wrote:
Tue May 29, 2018 3:15 pm
I am using v0.89 appimage on Ubuntu 18.04 64 bit. When I want to adjust a picture (etc via image > adjust > levels), a window opens where I can change the settings. If I move this window, the underlying picture window also moves. The adjustment window hides the picture window making the adjustment a blind flight.
In an earlier version the same thing happened, but another previous version worked correctly.
Unfortunately, I cannot remember which version was ok.
could you send me a screenshot?
N.B.: Version 0.90 does not let me access files on another drive (in Linux mounted via /mnt/dir), only the home folder can be used. Also a problem that occurred on earlier versions, but not in 0.89.
but there is no change here, you can't go to /mnt/dir folder?
Pierre.

hako
Posts: 3
Joined: Tue May 29, 2018 2:06 pm

Re: Linux - Main window moves with adjustment window

Post by hako » Tue May 29, 2018 9:05 pm

I am using version 0.89 appimage
Screenshot see attached: Trying to move the adjustment window out of the way, so that the picture gets visible, fails, because the main window moves with the sub-window. It is also not possible to get the picture window to the foreground, i.e. in front of the adjustment window.

I tried version 0.90, installed via snap (no appimage available). In that version I cannot access drives mounted via /mnt/something. xnviewmp 0.90 complains about lacking permission.On top of that, the a.m. window problem also occurs.

I guess there are different versions of dependencies used, but it can be that an earlier version would work. Do you have any idea which one I should try? Or, is there a setting I can try?
Attachments
subwindow_moves_main_window.png
when trying to move the Levels window, the main XnView MP window also moves

User avatar
xnview
Author of XnView
Posts: 29869
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Linux - Main window moves with adjustment window

Post by xnview » Mon Jun 04, 2018 9:57 am

hako wrote:
Tue May 29, 2018 9:05 pm
I am using version 0.89 appimage
Screenshot see attached: Trying to move the adjustment window out of the way, so that the picture gets visible, fails, because the main window moves with the sub-window. It is also not possible to get the picture window to the foreground, i.e. in front of the adjustment window.
It seems that it's a setting in window manager
I tried version 0.90, installed via snap (no appimage available). In that version I cannot access drives mounted via /mnt/something. xnviewmp 0.90 complains about lacking permission.On top of that, the a.m. window problem also occurs.
could you post a screenshot?
Pierre.

hako
Posts: 3
Joined: Tue May 29, 2018 2:06 pm

Re: Linux - Main window moves with adjustment window

Post by hako » Fri Jun 15, 2018 10:36 pm

Thank you very much! I found the window setting. My main problem is solved.
The other problem with version 0.90 I'll try to reproduce later, I need to install it.
Btw., is an appimg planned for 0.90?

Post Reply