Location of picture's changed! Categories?

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
masterdrummer
Posts: 1
Joined: Fri Jun 29, 2018 6:58 pm

Location of picture's changed! Categories?

Post by masterdrummer » Fri Jun 29, 2018 7:06 pm

Hi Guys.

I am using XnViewMP Version 0.84. Because i am working on different computers i installed it on an USB Drive.
Everything worked fine, all of my 10k+ pictures have a category and a Rating.

When i attach the USB drive to a computer and it get's another drive letter than bevfore everythink is broken. Xnview does not show me my pictures when i click on the category.
Everything (category and rating) ist stored in iptc and/or xmp.

Is there any way to get everything to work again?
Can i just get xnview to like import the categories from the files and write that to the db?
Or ist there a way to edit the xnview.db to change the location of the pictures from like N:/.... to O:/....

best regards,
- Alex

User avatar
xnview
Author of XnView
Posts: 30032
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Location of picture's changed! Categories?

Post by xnview » Sun Jul 01, 2018 12:55 pm

masterdrummer wrote:
Fri Jun 29, 2018 7:06 pm
When i attach the USB drive to a computer and it get's another drive letter than bevfore everythink is broken. Xnview does not show me my pictures when i click on the category.
Everything (category and rating) ist stored in iptc and/or xmp.
XnView stores categories/rating in database, with the pathname of pictures. So if you change the drive letter, it can't know how to get them.
Is there any way to get everything to work again?
Can i just get xnview to like import the categories from the files and write that to the db?
Or ist there a way to edit the xnview.db to change the location of the pictures from like N:/.... to O:/....
you can edit the database or use 'relocate' in settings>Catalog
Pierre.

alobo
Posts: 45
Joined: Sun Jun 18, 2017 3:24 pm

Re: Location of picture's changed! Categories?

Post by alobo » Sun Sep 16, 2018 8:27 pm

you can edit the database or use 'relocate' in settings>Catalog
To solve the same problem, I use relocate from e.g.

Old Path: D:\FOTOS\BDNMar\
New Path: E:\FOTOS\BDNMar\

Click OK and nothing changes.

Agus

User avatar
xnview
Author of XnView
Posts: 30032
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Location of picture's changed! Categories?

Post by xnview » Mon Sep 17, 2018 5:59 am

the path are not changed?
Pierre.

alobo
Posts: 45
Joined: Sun Jun 18, 2017 3:24 pm

Re: Location of picture's changed! Categories?

Post by alobo » Sat Sep 22, 2018 8:49 am

xnview wrote:
Mon Sep 17, 2018 5:59 am
the path are not changed?
No, look the consecutive screenshots: after OK in captura2, nothing changes (captura3).
https://www.dropbox.com/s/pr4h1q7d62tj6 ... 1.JPG?dl=0
https://www.dropbox.com/s/jgqdzfadqwvi2 ... 2.JPG?dl=0
https://www.dropbox.com/s/uycbismwqubuv ... 3.JPG?dl=0

Agus

User avatar
xnview
Author of XnView
Posts: 30032
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Location of picture's changed! Categories?

Post by xnview » Sun Sep 23, 2018 12:54 pm

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.

alobo
Posts: 45
Joined: Sun Jun 18, 2017 3:24 pm

Re: Location of picture's changed! Categories?

Post by alobo » Sun Oct 07, 2018 2:03 pm

xnview wrote:
Sun Sep 23, 2018 12:54 pm
:bugconfirmed: Thanks to your detailed description I can reproduce
Just updated to Version 0.92 64bits (Sep 18 2018) but the problem persists.
Is this problem going to be fixed soon?
Thanks

viewfan
Posts: 9
Joined: Thu Oct 10, 2013 2:43 pm

Re: Location of picture's changed! Categories?

Post by viewfan » Mon Oct 15, 2018 11:08 am

I have the same Problem :(
@xnview
you can edit the database ...
which encoding has the databas? Which encoding do I have set to edit it on linux with Kate for instance?

viewfan
Posts: 9
Joined: Thu Oct 10, 2013 2:43 pm

Re: Location of picture's changed! Categories?

Post by viewfan » Mon Oct 15, 2018 1:27 pm

I found a solution. See this thread down.

viewtopic.php?f=82&t=38046&p=152521#p152521

Post Reply