categories IPTC/XMP search etc.

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
mir
Posts: 3
Joined: Thu Apr 06, 2017 10:13 am

categories IPTC/XMP search etc.

Post by mir » Wed Dec 12, 2018 3:24 pm

I've been using Xnview or Xnviemo for a long time and it's the best program to browse photos.
Now I have spent days with various tests tagging my pictures . But there are so many unreasonablenesses and mistakes that I wonder if anyone here works successfully with categories.

for example:
Although all fields"export categories etc.) are enabled, no data is written to the IPTC of the photo.
The search for IPTC keywords never shows anything, even though some files contain the keywords.
The number of images in the categories is twice as large as the number of images displayed.
Then again, no pictures are displayed although there is a high number in the respective category.

User avatar
xnview
Author of XnView
Posts: 30411
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: categories IPTC/XMP search etc.

Post by xnview » Thu Dec 13, 2018 1:22 pm

mir wrote:
Wed Dec 12, 2018 3:24 pm
Although all fields"export categories etc.) are enabled, no data is written to the IPTC of the photo.
The search for IPTC keywords never shows anything, even though some files contain the keywords.
could you send me a picture file to reproduce?
Pierre.

User avatar
michel038
Posts: 258
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: categories IPTC/XMP search etc.

Post by michel038 » Thu Dec 13, 2018 1:25 pm

Edit - - - Sorry, I didn't see xnview answer

- Did you use a "Base path of your pictures" in "settings, Catalog" screen ? If yes, I think it's the main problem.
This problem may cause all the bugs you described.
- The second problem is only in V0.92 version and it prevents solving the first one.
When 'Use database" is used in search windows, no results are found. ( see viewtopic.php?f=62&t=38100)
- Third problem, your catalog may be damaged : see the last item in this message.
Although all fields"export categories etc.) are enabled, no data is written to the IPTC of the photo.
Are you using jpeg photos ?
Are your photos in a hard disk drive or a network drive ?
Are you using categories or "edit iptc/xmp" window ? (these two methods use different settings)
The search for IPTC keywords never shows anything, even though some files contain the keywords.
Are you using "categories filter" panel ? Perhaps your catalog is damaged
Are you using V0.92 and "search" function with "use database" ? (known bug , pb 2)
The number of images in the categories is twice as large as the number of images displayed.
This occurs sometimes, I think when both "import" and "export" options are enabled (settings, metadata) . I don't know how to reproduce.
Could you try : (1) settings, catalog, Check integrity of catalog at startup ? (and restart)
(2) settings, catalog, Optimize with all options checked unless "purge files" and "purge thumbnails" ... wait for process and restart xnviewmp.
Then again, no pictures are displayed although there is a high number in the respective category.
You mean with categories filter ?
First, select the parent folder in "Folders" pane.
Then , in Categories filter pane, check "Match" menu : use "global" or "current folder, recursive". Please try first with only one category.

Perhaps you will have to rebuild your catalog, if metadata are embedded in your photos.
see viewtopic.php?f=82&t=32401

Post scriptum , I'm using two instances of XnViewMP.
One for my own usage, with wich I'm very careful. I never try a new option or a new version with this one.
A second one for tests, with 5 - 20 images. In this one, I can delete, rebuild catalog etc ... When the method is OK, I can apply it in the first Xnviewmp.

Post Reply