Why TWAIN interface window for scanner always in background

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
tacitus5
Posts: 1
Joined: Sat Feb 09, 2019 9:49 pm

Why TWAIN interface window for scanner always in background

Post by tacitus5 » Sat Feb 09, 2019 10:19 pm

System: MS Windows 10, Version 1809

Program used: XnView MP Windows; Version 0.93 64bits (Jan 31 2019); Libformat version 7.25

Most of the time I use the software in connection with a flatbed scanner (with Twain Interface : WIA-WIA-Canoscan 5600F 1.0 32:32).
Since I first installed XnView MP, the TWAIN interface opens always in the background, so I don't see it is active until I "ALT-TAB" through all open windows.

I downloaded XnView MP about two months ago; before that I used XnView, and with the older XnView the TWAIN interface opened in the foreground (displaying above the XnView window) with the same TWAIN interface and same physical flatbed scanner. I wonder why this is so.

Is there a way to change the behaviour of the Twain interface window to come up in the foreground again? I didn't find anything in the Settings for Xn View MP.

Because this behaviour is somewhat annoying, I even tried to switch back to XnView, which is still installed, but somehow the old XnView cannot communicate with the TWAIN interface anymore. (reason unknown)

Am I doing something wrong, did I miss an something or is it windows bug or whatever - help is appreciated

Any ideas?

User avatar
xnview
Author of XnView
Posts: 30699
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Why TWAIN interface window for scanner always in background

Post by xnview » Sat Feb 16, 2019 1:32 pm

tacitus5 wrote:
Sat Feb 09, 2019 10:19 pm
Is there a way to change the behaviour of the Twain interface window to come up in the foreground again? I didn't find anything in the Settings for Xn View MP.
Each time, scan dialog is opened in background?
Because this behaviour is somewhat annoying, I even tried to switch back to XnView, which is still installed, but somehow the old XnView cannot communicate with the TWAIN interface anymore. (reason unknown)
Do you have selected the good TWAIN source?
Pierre.

Post Reply