Page 1 of 2

No automatic update of fresh saved images at the thumbnails

Posted: Sat Sep 28, 2019 7:03 am
by Micha
Hi,

it was never a problem at XnView Classic but at MP the files of the directory are not automatic refreshed always. For example if I save images per V-Ray or AI Gigapixel than this new images are not shown at the current directory. I need to switch to an other directory and back to get an updated view of all thumbnails. Images saved from Photoshop are shown.

Best-
Micha

Re: 0.94 beta 2 - no automatic update of fresh saved images at the thumbnails

Posted: Sat Sep 28, 2019 9:06 am
by xnview
do you have such problem with 0.93.1?

Re: 0.94 beta 2 - no automatic update of fresh saved images at the thumbnails

Posted: Sat Sep 28, 2019 10:00 am
by Micha
Yes, I tested it today again.

Re: 0.94 beta 2 - no automatic update of fresh saved images at the thumbnails

Posted: Sat Sep 28, 2019 10:02 am
by Micha
Photoshop works, but not saved images from V-Ray.

Re: No automatic update of fresh saved images at the thumbnails

Posted: Thu Oct 10, 2019 12:08 pm
by Micha
As workaround could it be possible to get F5 working for forcing a directory upadte?

Re: No automatic update of fresh saved images at the thumbnails

Posted: Mon Oct 14, 2019 5:26 am
by Micha
I found an issue like this and it looks like it can be repeated without additional tools. I drag&drop an image from one XnView MP task to an other. The image isn't read and the thumbnail not shown like at the source folder.

Re: No automatic update of fresh saved images at the thumbnails

Posted: Wed Nov 13, 2019 1:07 pm
by xnview
Micha wrote:
Mon Oct 14, 2019 5:26 am
I found an issue like this and it looks like it can be repeated without additional tools. I drag&drop an image from one XnView MP task to an other. The image isn't read and the thumbnail not shown like at the source folder.
and you can reproduce each time?

Re: No automatic update of fresh saved images at the thumbnails

Posted: Wed Nov 13, 2019 1:18 pm
by Micha
At beta 3 the copy from one MP task to an other works, also if I save from photoshop.

But if I save renderings from V-Ray, than V-Ray for example saves four images alpha/denoise/material_ID/effects. But the automatic saved "effects" image isn't shown, only the three other images. After jumping to an other directory and back the missing image is shown too. Interesting, it was the first saved image of the series which wasn't shown.

Re: No automatic update of fresh saved images at the thumbnails

Posted: Fri Nov 29, 2019 9:48 am
by Micha
I still have the problem, also if I use other software for saving images to the current directory. It could be really useful to update the view per F5. ;)

Re: No automatic update of fresh saved images at the thumbnails

Posted: Fri Nov 29, 2019 10:59 am
by xnview
Micha wrote:
Fri Nov 29, 2019 9:48 am
I still have the problem, also if I use other software for saving images to the current directory. It could be really useful to update the view per F5. ;)
Known issue

Re: No automatic update of fresh saved images at the thumbnails

Posted: Tue Feb 18, 2020 4:40 pm
by Micha
I'm not sure it's the same issue. Here XnView shows the thumbnail images of a folder and If I save images to this folder per software like V-Ray than only a few or no new thumbnails of the fresh files are added.

Forcing an update per F5 could be a good workaround. At the moment I need to jump to an other directory and back to get all thumbnails shown.

Re: No automatic update of fresh saved images at the thumbnails

Posted: Mon Mar 23, 2020 6:46 am
by Micha
I installed the latest beta yesterday and the problem still persist. I have a directory with thumbnails, but if I save a new file to this directory, than the new image isn't shown. I need to switch to an other directory and back to get the thumbnails updated. At XnView classic it was never an issue. Could you please make it working like at Classic? Every time I use XnView I run in this issue. A manual refresh would be find too as a first step.

Best regards,
Micha

Re: No automatic update of fresh saved images at the thumbnails

Posted: Mon Mar 23, 2020 4:14 pm
by xnview
Micha wrote:
Mon Mar 23, 2020 6:46 am
I installed the latest beta yesterday and the problem still persist. I have a directory with thumbnails, but if I save a new file to this directory, than the new image isn't shown. I need to switch to an other directory and back to get the thumbnails updated. At XnView classic it was never an issue. Could you please make it working like at Classic? Every time I use XnView I run in this issue. A manual refresh would be find too as a first step.
I don't have this problem. Which filter do you use?

Re: No automatic update of fresh saved images at the thumbnails

Posted: Mon Mar 23, 2020 5:21 pm
by Micha
For example the standard "image" filter mode. If I save per latest V-Ray or Oloneo Photoengine than the thumbnails are not updated, if I save per Photoshop CS4 or Affinity Photo than the new saved file are shown at the thumbnails. I don't know why the output of some programs is ignored.

Also some times I have seen that the small size (low MB) output images from V-Ray are shown - for example if I save an image of 4000x2000 than the alpha channel and material ID are shown, but not the large size beauty pass.

Re: No automatic update of fresh saved images at the thumbnails

Posted: Tue Mar 31, 2020 4:12 pm
by xnview
could you send me a sample file that you save? Windows 10?