Help! Keywords keep disappearing!

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, helmut, xnview

CatB
Posts: 3
Joined: Mon Jan 22, 2024 6:21 pm

Help! Keywords keep disappearing!

Post by CatB »

I am so hoping someone can help me troubleshoot this problem. So I have spent hours and hours recently adding keywords (to IPTC metadata) while viewing my digital pix in Xn View. For some reason, I decided to go back after tagging a whole bunch, just to double check, Well, a bunch of them did not "stick". They were gone! Or on some pix, if I added 5 keywords, maybe 1 or 2 were still there but the others were gone. And on some pix, they were all still there.

And ironically, when I view a picture who's keywords are no longer showing under IPTC, when I look at the checked off "Categories" list on the bottom right, those keywords ARE still checked off, as if XnView remembers them, but they are just not showing under IPTC details on the bottom left.

This continues to happen and I have absolutely NO IDEA why! Needless to say, I am now going to need to go back as far as I can remember and see if this has been happening for longer than I even thought.

Has anyone ever had this happen and if so, any idea why? I am desperate to troubleshoot this issue, as I really rely on tagging my photos so I can find the ones I need when I need them.

Thanks in advance for any help you all can provide :)

Cat
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Help! Keywords keep disappearing!

Post by xnview »

do you add your keywords with 'Edit IPTC' dialog? on jpeg files?
Pierre.
CatB
Posts: 3
Joined: Mon Jan 22, 2024 6:21 pm

Re: Help! Keywords keep disappearing!

Post by CatB »

xnview wrote: Tue Jan 23, 2024 7:47 am do you add your keywords with 'Edit IPTC' dialog? on jpeg files?
Once in Xn View, I hit CTRL + i and it brings up the "Edit IPTC" box. From there, I choose "keywords" (2nd option on top), type in the keywords I want, then hit "Write". And the keywords then show up in the lower left box but moments (or longer) later, when I go back and recheck, there are always several pix where many of the keywords are gone (at least one or two will still be there, but not all.

Any thoughts?
User avatar
xnview
Author of XnView
Posts: 43098
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Help! Keywords keep disappearing!

Post by xnview »

how do you reproduce? please send me test files
Pierre.
CatB
Posts: 3
Joined: Mon Jan 22, 2024 6:21 pm

Re: Help! Keywords keep disappearing!

Post by CatB »

xnview wrote: Tue Jan 23, 2024 4:16 pm how do you reproduce? please send me test files
Sorry for the ignorance, but I consider myself a true "newbie" here. I am using XnView at home to organize my personal digital pix. Not sure what you mean by "how do you reproduce" and not sure how to send test files. If you could be patient and explain to me, I would greatly appreciate it and send that info along.

On a side note, when I first posted this, I was under the impression that the issue was with XnView but now I am thinking it might be more than that. Here is how I tested that theory. I also have ACDSee Photo Professional 2022 program. I decided to tag a few pix with that as well and the same thing happened. Some tags stuck, some did not.

Fast forward to the next test (as I thought it was too coincidental that 2 software program would be having the same issue!). I went into Windows Explorer and accessed my pix that way. Right clicked > properties > details > keywords, then typed in the keywords I wanted assigned to the IPTC metadata of that pic. Guess what? Same thing happened!

So, not sure why this is occurring. The only thing that I can think of that has changed since the last time I spent time tagging pictures is that I upgraded my laptop to Windows 11 from Windows 10. But not sure if that is relevant.

Any thoughts would be very much appreciated.