Filtrage avec ET, un presque bug

Questions générales en Français

Moderators: XnTriq, xnview

michel038
Posts: 97
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Filtrage avec ET, un presque bug

Postby michel038 » Mon Jul 31, 2017 8:53 pm

Bonjour,
Supposons que je veuille afficher des photos contenant les mots clés "fleur" ET "insecte"
Dans le filtre catégories je clique "fleur" puis , avec la touche Ctrl , "insecte"
Or, si le premier clic a bien sélectionné "fleur" et uniquement "fleur", le deuxième clic a sélectionné "insecte" et toutes les sous-catégories d'insectes.

Et comme un insecte ne peut pas être à la fois un papillon, une mouche et un scarabée, on obtient zéro résultat.
Il faut donc déployer la catégorie "insecte", puis désélectionner toutes les sous catégories pour avoir le résultat souhaité ...

Je trouverais plus logique et efficace qu'une sélection avec Ctrl ne sélectionne pas les sous-catégories.

C'était peut-être voulu, pour favoriser les OU au détriment des ET ? :P
On peut d'ailleurs remarquer qu'en sélectionnant une seule catégorie avec la touche Ctrl maintenue, toutes les sous catégories sont aussi sélectionnées.

User avatar
xnview
Author of XnView
Posts: 28298
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Filtrage avec ET, un presque bug

Postby xnview » Tue Aug 01, 2017 11:07 am

lorsque vous cliquez avec CTRL sur une catégorie, toutes les sous catégories sont selectionnées?
pourriez vous m'envoyer une copie ecran de settings>Metadata?
Pierre.

michel038
Posts: 97
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Filtrage avec ET, un presque bug

Postby michel038 » Tue Aug 01, 2017 3:48 pm

Oui, c'est bien ça. Dans le filtre des catégories.

OS : Win7 professionnel
XnviewMP V0.87 beta2

Bien vu Pierre !
C'est l'option "Automatically apply parent keywords" qui provoque cet effet
Si j'enlève l'option, le problème disparait. Mais je préfèrerais pouvoir la laisser cochée !

Image

User avatar
xnview
Author of XnView
Posts: 28298
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Filtrage avec ET, un presque bug

Postby xnview » Tue Aug 01, 2017 8:25 pm

michel038 wrote:Bien vu Pierre !
C'est l'option "Automatically apply parent keywords" qui provoque cet effet
Si j'enlève l'option, le problème disparait. Mais je préfèrerais pouvoir la laisser cochée !

oui, l'utilisation de cette option selectionne effectivement l'arborescence avec CTRL
Pierre.

michel038
Posts: 97
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Filtrage avec ET, un presque bug

Postby michel038 » Wed Aug 02, 2017 10:18 pm

Le libellé de cette option ne dit pas qu'elle a une influence sur le filtre des catégories ...

En attendant mieux, je la décoche.
Et comme je continue à mettre des mots clés avec leurs parents dans mes photos, je fais un Ctrl-clic quand j'assigne ...

Dans la même famille de petites améliorations possibles, quand on utilise la boite de recherche de catégories pour assigner, l'option "apply parent keywords" est inopérante. Bon, ce n'est pas très grave.


Return to “MP - General [Français]”

Who is online

Users browsing this forum: No registered users and 2 guests