Page 1 of 2

0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Tue Aug 29, 2017 11:44 pm
by dreg
XnViewMP 0.87beta3
Windows10pro64

Bonjour,

J'ai constaté un problème reproductible lorsqu'on renomme un dossier (par WXnViewMP)
Apparemment l'information n'est pas bien transmise au niveau de la base de donnée des catégories et des liens avec les vignettes :

1- soit un dossier "TEST" contenant des photos liées à la catégorie "1"
2- dans le mode Filtre de catégorie si on clique sur l'intitulé "1", toutes les vignettes des photos appartenant à catégorie "1" sont bien répertoriées dans la fenêtre d'affichage des vignettes
3- si on renomme le dossier "TEST" en "TEST bug" par XnViewMP, que l'on retourne dans le mode "Filtre de catégorie", et que l'on clique sur la catégorie "1" : les vignettes n'apparaissent plus (elles sont remplacées par une icône d'ordinateur avec une fenêtre en arrière-plan) et leurs libellés ne comprennent plus que le nom des photos : toutes les autres informations ont disparu (paramètres de prise de vue, mots clés si on l'a paramétré, etc ...)
Un double-clic sur ces vignettes n'ouvre plus les photos.
4- si on renomme le dossier "TEST bug" en "TEST" : tout rentre dans l'ordre dans le mode Filtre de catégorie et l'affichage des vignettes et leurs libellés sont à nouveau normaux

On dirait qu'il s'agit d'une absence de mise à jour de la base de donnée des catégories contenue dans le fichier XnView.db
Non ?

Merci d'avance si vous parvenez à résoudre ce bug

Re: 0.87b3 : Problème de mise à jour des vignettes en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Thu Sep 07, 2017 1:03 pm
by xnview
vous renommez le dossier dans la vue vignettes ou dossiers ou depuis l'explorateur windows?

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Fri Sep 08, 2017 1:45 pm
by dreg
Bonjour,
dans la vue vignettes, dans la colonne des dossiers, à gauche

Re: 0.87b3 : Problème de mise à jour des vignettes en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Wed Sep 13, 2017 11:19 am
by xnview
je n'arrive pas à reproduire, et avec la 0.87?

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Wed Sep 13, 2017 9:47 pm
by dreg
XnViewMP 0.87
Windows10pro64

Bonjour,
le problème persiste chez moi en version 0.87 finale
je détaille la procédure pour reproduire le bug :

1- dans l'explorateur, onglet Dossier, soit un dossier "TEST" contenant des photos (=dossier créé par l'explorateur Windows10 bien auparavant)
2- attribuer une catégorie "1" (par ex) à une photo
3- aller dans l'onglet Filtre de catégorie : si on clique sur l'intitulé "1", la vignette de la photo appartenant à catégorie "1" est bien répertoriée dans la fenêtre d'affichage des vignettes et elle s'ouvre. Normal
4- retourner dans l'onglet Dossier : on renomme le dossier "TEST" en "TEST bug" par un clic droit
5- retourner dans le mode "Filtre de catégorie", cliquer sur la catégorie "1" : l'aperçu dans la vignette n'apparait plus (il est remplacé par une icône d'ordinateur avec une fenêtre en arrière-plan) et les libellés, dessous, ne comprennent plus que le nom de la photo : toutes les autres informations ont disparu (paramètres de prise de vue, mots clés si on l'a paramétré, etc ...)
Un double-clic sur cette vignette sans aperçu de la photo, dans l'onglet "filtre de catégories", n'ouvre plus la photos.
6- si on renomme le dossier "TEST bug" en "TEST" : tout rentre dans l'ordre dans le mode Filtre de catégorie et l'affichage de la vignette et les libellés sont à nouveau normaux

Arrivez-vous à ouvrir la vignette présentée dans l'onglet "filtre catégorie", en choisissant la catégorie "1", suite à la modification du nom du dossier le contenant ? => chez moi ça ne marche pas

Si on ferme XnviewMP et qu'on rouvre le programme et qu'on retourne dans l'onglet "Filtre de catégories" : la vignette est mise à jour mais un double clic sur celle-ci n'ouvre pas le fichier.

Merci d'avance

Re: 0.87 : Problème de mise à jour des vignettes en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Thu Sep 14, 2017 2:11 pm
by michel038
Windows7 pro, V0.87 64
Le bug ne se produit pas pour moi ...

Dans outils, options, catalogue
- que contient votre case "répertoire de base pour les images" ?
- J'ai augmenté la taille mémoire pour la base de données à 400 Mo (mon xnview.db fait 160Mo)
- Avez-vous essayé "optimisation" avec les coches 2,5,6 ou 1,2,5,6 ?

Image

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Thu Sep 14, 2017 7:54 pm
by dreg
Bonjour michel038,
Merci pour l'aide, le répertoire de base pour les images est le dossier contenant les répertoires de mes photos.
J'ai aussi tenté vos solutions mais le problème persiste

Par contre, je pense avoir trouvé l'origine du bug chez moi.
en suivant la procédure :

1- dans l'explorateur, onglet Dossier, soit un dossier "TEST" contenant des photos (=dossier créé par l'explorateur Windows10 bien auparavant)
2- attribuer une catégorie "1" (par ex) à une photo de ce dossier "TEST"
3- aller dans l'onglet Filtre de catégorie : si on clique sur l'intitulé "1", la vignette de la photo appartenant à catégorie "1" est bien répertoriée dans la fenêtre d'affichage des vignettes et elle s'ouvre. Normal
4- retourner dans l'onglet Dossier : on renomme le dossier "TEST" en "TEST bug" par un clic droit

=> sans quitter l'onglet "Dossier" en mode explorateur, la catégorie "1" n'est plus cochée dans la colonne des catégories à droite, si on sélectionne la photo par un simple clic

Est-ce que c'est parce que le dossier "TEST" a été créé par Windows, que la base de donnée xnview.db n'est pas mise à jour si on modifie le nom du dossier "TEST" par l'explorateur d'XnViewMP ?

Merci d'avance.

Re: 0.87 : Problème de mise à jour des vignettes en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Thu Sep 14, 2017 9:31 pm
by michel038
Mes dossiers de photos sont aussi créés sous windows, quand je recopie mes cartes mémoire. Et je n'ai jamais eu de pb de ce type.

Par contre, le "répertoire de base pour les images" lorsqu'il est renseigné, provoquait un bug dans le filtre des catégories, les options "dossier courant" et "dossier courant récursif" du menu "Correspond" ne fonctionnaient pas ( versions V0.82 -0.84 il me semble )
Depuis, je me méfie de cette case et je la laisse vide, (mais à quoi sert-elle ?) et je ne sais pas si le bug a été résolu.

Si vous voulez l'effacer, la base de données ne marchera plus, il faudra la reconstruire ( ou utiliser un export de "catégories fichiers" préalable , puis un import après , ça pourrait suffire et c'est bien plus rapide)

Pour cette manip, recherchez dans mon tuto les mots : catégories fichier

Re: 0.87 : Problème de mise à jour des vignettes en mode "filtre de catégorie" lorsqu'on renomme un dossier

Posted: Fri Sep 15, 2017 1:25 pm
by xnview
toujours pas :( quels sont vos parametres dans metadata?

Re: 0.87 : 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme

Posted: Fri Sep 15, 2017 10:28 pm
by dreg
Bonjour, voici mes paramètres des métadonnées :

Capture.JPG

Merci d'avance

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Fri Sep 15, 2017 10:53 pm
by dreg
Voici en image ce qu'il se passe :

étape 1 + 2 :
1.jpg

étape 3 :
2.jpg

étape 4 :
3.jpg

étape 5 : en fait, la vignette est bien mise à jour (en passant quand même par l'étape d'icône d'ordinateur) si on change de filtre de catégorie et que l'on revient sur la catégorie "0 - à trier" mais les plus gros soucis sont que les libellés ont disparus et que la photo ne s'ouvre pas !
5.jpg

4.jpg


Je vais renommer le titre du fil car ce n'est pas un problème de vignette mais un problème d'ouverture de photo et de perte de libellés

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Sat Sep 16, 2017 10:26 am
by michel038
J'ai écrit
Par contre, le "répertoire de base pour les images" lorsqu'il est renseigné, provoquait un bug dans le filtre des catégories, les options "dossier courant" et "dossier courant récursif" du menu "Correspond" ne fonctionnaient pas ( versions V0.82 -0.84 il me semble )
Depuis, je me méfie de cette case et je la laisse vide, (mais à quoi sert-elle ?) et je ne sais pas si le bug a été résolu.


C'est bien la case "répertoire de base pour les images" qui pose problème.
J'ai reproduit le bug, lorsque cette case est renseignée.

(l'autre bug que je citais, concernant "dossier courant" est résolu, ça concerne un autre post)

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Sat Sep 16, 2017 1:23 pm
by dreg
Bonjour,
J'ai fait un test en effaçant la case du répertoire de base pour les images dans les options du catalogues (on se retrouve quand même avec le répertoire racine (\) de l'ordinateur) : mais c'est une vrai galère avec les catégories.

Aussi bien en mode Dossiers que Filtre des catégories, les catégories ne sont plus cochées dans le panneau de droite lorsqu'on sélectionne une photo, et donc on ne sait plus s'il faut réattribuer une catégorie ou non ...

En fait, par rapport au problème que j'ai expliqué depuis le début (case du répertoire de base remplie ...) :
en mode "filtre de catégorie" c'est le cache qui n'est pas mis à jour automatiquement quant on renomme un dossier par XnViewMP : il suffit de regarder les propriétés en sélectionnant la vignette de l'icône en forme d'ordinateur (ou la vignette rafraichie mais qui ne s'ouvre pas en double-cliquant dessus) pour voir que le nom du répertoire contenant la photo n'est n'a pas été modifié malgré son renommage.

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Sat Sep 16, 2017 3:20 pm
by xnview
dreg wrote:J'ai fait un test en effaçant la case du répertoire de base pour les images dans les options du catalogues (on se retrouve quand même avec le répertoire racine (\) de l'ordinateur) : mais c'est une vrai galère avec les catégories.

Aussi bien en mode Dossiers que Filtre des catégories, les catégories ne sont plus cochées dans le panneau de droite lorsqu'on sélectionne une photo, et donc on ne sait plus s'il faut réattribuer une catégorie ou non ...

Vous ne pouvez pas changer le 'base path' comme ça sans que l'ensemble des categories se retrouvent faussées.

Je vais regarder le probleme

Re: 0.87 : Problème d'ouverture de photo et de perte de libellés en mode "filtre de catégorie" lorsqu'on renomme un doss

Posted: Sat Sep 16, 2017 3:51 pm
by michel038
Dreg a écrit
en effaçant la case du répertoire de base pour les images (...) Aussi bien en mode Dossiers que Filtre des catégories, les catégories ne sont plus cochées dans le panneau de droite lorsqu'on sélectionne une photo, et donc on ne sait plus s'il faut réattribuer une catégorie ou non ...

oui, c'est ce que je disais :

Si vous voulez l'effacer, la base de données ne marchera plus, il faudra la reconstruire ( ou utiliser un export de "catégories fichiers" préalable , puis un import après , ça pourrait suffire et c'est bien plus rapide)


faire un
export de "catégories fichiers" préalable , puis un import après
Pour cette manip, recherchez dans mon tuto les mots : catégories fichier

ça fonctionne bien