Page 3 of 4

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 10:12 am
by michel038
Il m'est arrivé d'utiliser "Process monitor" de Sysinternals pour découvrir ce qui bloquait certains logiciels. Mais c'est pas commode, il faut utiliser des filtres pour cibler les évènements ...
Autre avantage de Process monitor, c'est qu'on peut débusquer des trucs inutiles (windows media player par exemple) et consommateurs de ressources machine.

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 10:23 am
by freewee
xnview wrote:
Sun Dec 16, 2018 9:34 am
freewee wrote:
Sun Dec 16, 2018 9:26 am
apparition du terminal?? qtlinguist ne lance pas de terminal
Bon je n' ai peut être pas fait ce qu' il faut:
j' ai decompressé linguist.exe, placé dans le dossier de XnView MP , lancé XnViewmp.exe... et j' obtiens un terminal suivi immédiatement de l' explorateur, donc 7-8 secondes de delai pour premier demarrage dans W10.

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 10:25 am
by freewee
michel038 wrote:
Sun Dec 16, 2018 10:12 am
Il m'est arrivé d'utiliser "Process monitor" de Sysinternals pour découvrir ce qui bloquait certains logiciels. Mais c'est pas commode, il faut utiliser des filtres pour cibler les évènements ...
Autre avantage de Process monitor, c'est qu'on peut débusquer des trucs inutiles (windows media player par exemple) et consommateurs de ressources machine.
Merci, j' ai effectivement ça dans mes outils, mais pour le moment un peu limité en temps!!!

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 10:49 am
by xnview
freewee wrote:
Sun Dec 16, 2018 10:23 am
Bon je n' ai peut être pas fait ce qu' il faut:
j' ai decompressé linguist.exe, placé dans le dossier de XnView MP , lancé XnViewmp.exe... et j' obtiens un terminal suivi immédiatement de l' explorateur, donc 7-8 secondes de delai pour premier demarrage dans W10.
Ah désolé, en fait c'est lancer linguist. Cet exe ne change en rien le comportement de xnview

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 11:24 am
by freewee
OK retour à W7 Avast désactivé, car W10 a bloqué le fichier ainsi qu' Avast qui n' a rien trouvé d' anormal finalement:
Donc pour linguist: splash à 4-5 secondes et fenêtre à 8 secondes...

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 1:04 pm
by xnview
freewee wrote:
Sun Dec 16, 2018 11:24 am
OK retour à W7 Avast désactivé, car W10 a bloqué le fichier ainsi qu' Avast qui n' a rien trouvé d' anormal finalement:
Donc pour linguist: splash à 4-5 secondes et fenêtre à 8 secondes...
Donc à peu pres comme la 0.92 ou beta.
Sur ces 2 machines, vous n'avez rien de special? Peut etre en essayant d'installer https://aka.ms/vs/15/release/vc_redist.x64.exe

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 3:53 pm
by freewee
En ce qui concerne le matériel:
- PC de bureau, multiboot W7 64b W10 64b Ubuntu 18.04 64b, sur SSD GPT +2 autres HDD, Core I5 2500K 3.3Ghz, CG Quadro FX 4800 NVidia. Profil ecran établi par par sonde Eye One Display
- PC portable Dell XPS 17, multiboot W7 et Ubuntu 18.04 64b sur SSD MBR, W10 64b sur HDD, Core i7 2670QM 2.2 GHz, CG GeForce 555M NVidia, profil écran idem.
Les 2 PC réagissent de façon similaire sauf W10 sur le PC portable, qui n' est pas sur SSD et est plus lent!!!
Je vais voir avec vc!

Re: Ouverture XnView MP très lente

Posted: Sun Dec 16, 2018 6:39 pm
by freewee
Bon Microsoft vc 2017 installé, nouveau test de la béta, ouverture terminal et fenêtre quasi en même temps, delai 4-5s, donc mieux!
Je re teste donc la 0.92, on arrive à 6 secondes sans les plugins .
Un peu mieux donc.
Mais comme je le précisais plus haut, la particularité de presque tous mes programmes est d' être installés sur un disque différent du système d' exploitation, depuis longtemps et sans problèmes.
J' ai donc tenté d' installer XnView avec les options par défaut, à savoir sur C:\Progammes, cette partition étant de plus sur le SSD: la version 0.92 démarre en 2-3 secondes, avec les plugins. Soit normalement!!!
Plusieurs questions donc, car Xnview a toujours été installé sur partition différente du système d' exploitation, qui est partagée par les 2 Windows,7 et 10, pour documents, programmes, bureau etc...
Et ce n' est qu' a partir d' une certaine version que j' ai ressenti une nette augmentation du délai de démarrage... De plus je n' ai pas ressenti de ralentissement pour mes autres programmes.
Si personne d' autre n' a évoqué le problème, on peu supposer que le problème est spécifique à ma configuration, et le seul remède sera d' installer XnView sur C:\...
Je vais tester avec mon W10 installé sur HDD qui me donnait des délais supérieurs à 15 secondes...

Re: Ouverture XnView MP très lente

Posted: Mon Dec 17, 2018 7:51 am
by xnview
du coup la beta demarre plus vite, avec tous les plugins?
Etrange que cela soit lié au disque...

Re: Ouverture XnView MP très lente

Posted: Mon Dec 17, 2018 8:35 am
by freewee
Bonjour

Windows 7, XnViewMP 0.92 installé sur la partition principale (j' ai repris mon installation antérieure, paramètres, plugins etc...), pas de délai notable à la première ouverture, même en utilisant Shell extension pour ouvrir une image...
Avec Windows 10, même machine et même configuration, on sent une certaine lenteur au démarrage, mais pas au point d' ouvrir un fil pour ça!
XnViewMP 0.92 installé sur un autre disque, augmentation notable du premier démarrage, quasiment doublé avec les plugins...
J' ai verifié mes partitions, disques, sans trouver d' anomalie particulière.
En ce qui concerne la beta, avec tous les plugins, dossier sur le disque principal, même comportement, c' est rapide dans Windows 7, un peu moins dans Windows 10, et le délai augmente nettement lorsque le dossier est sur un autre disque!
Le pire des délai a été sur mon portable, un peu moins puissant mais correct quand même, avec Windows 10 sur HDD (5200t/mn seulement), XnView sur le même disque, mais partition différente de la partition principale: pratiquement 20 secondes avec les plugins!!!Je me demande à chaque fois si j' ai bien cliqué!!

Re: Ouverture XnView MP très lente

Posted: Mon Dec 17, 2018 8:43 am
by xnview
freewee wrote:
Mon Dec 17, 2018 8:35 am
Le pire des délai a été sur mon portable, un peu moins puissant mais correct quand même, avec Windows 10 sur HDD (5200t/mn seulement), XnView sur le même disque, mais partition différente de la partition principale: pratiquement 20 secondes avec les plugins!!!Je me demande à chaque fois si j' ai bien cliqué!!
Et vous n'avez pas de delai aussi important avec d'autres apps (par ex. google earth qui utilise aussi QT)? Meme en installant le redist vc?

Re: Ouverture XnView MP très lente

Posted: Mon Dec 17, 2018 10:23 am
by freewee
xnview wrote:
Mon Dec 17, 2018 8:43 am
freewee wrote:
Mon Dec 17, 2018 8:35 am
Le pire des délai a été sur mon portable, un peu moins puissant mais correct quand même, avec Windows 10 sur HDD (5200t/mn seulement), XnView sur le même disque, mais partition différente de la partition principale: pratiquement 20 secondes avec les plugins!!!Je me demande à chaque fois si j' ai bien cliqué!!
Et vous n'avez pas de delai aussi important avec d'autres apps (par ex. google earth qui utilise aussi QT)? Meme en installant le redist vc?
J' ai une version de Google earth de 2016 sur mon PC de bureau
Elle est installée sur ma partition des programmes en dehors de l' OS, et de plus son fichier temporaire est sur une autre partition, ces 2 partitions n' étant pas sur SSD. J' ai 3-4 secondes pour le spash screen suivi quasi immédiatement par la fenêtre ou apparait progressivement l' animation de la terre qui grossit et tourne...
Je pense avoir la même version sur mon portable, je vais réveiller W10 dessus!

Re: Ouverture XnView MP très lente

Posted: Mon Dec 17, 2018 1:51 pm
by freewee
J' ai abandonné l' idée d' utiliser mon portable avec Windows 10 pour ce genre de tests, car c' est catastrophique sur un HDD normal.
Dell a décrété (je ne sais pas pour quelle raison) que le "fleuron" de sa gamme le XPS 17 n' était pas compatible W10; J' ai quand même pu l' installer en multiboot, conservant précieusement W7 qui fonctionne bien. C' est vrai que W10 est toujours en train d' accaparer les ressources et semble toujours en train de ramer, et je n' ai pas trouvé d' amélioration à faire...
Retour à W7 sur mon portable, c' est comme le PC de bureau, rapide quand XnView installé sur C:\Programmes, ralenti quand installé sur une autre partition , d' autant plus que les plugins sont dans le dossier!

Re: Ouverture XnView MP très lente

Posted: Tue Dec 18, 2018 7:58 am
by xnview
freewee wrote:
Mon Dec 17, 2018 1:51 pm
Retour à W7 sur mon portable, c' est comme le PC de bureau, rapide quand XnView installé sur C:\Programmes, ralenti quand installé sur une autre partition , d' autant plus que les plugins sont dans le dossier!
Etrange quand meme, je viens d'essayer sur W10, en installant XnViewMP sur HDD, mais pas plus que 2s la 1ere fois :(

Re: Ouverture XnView MP très lente

Posted: Tue Dec 18, 2018 9:18 am
by freewee
Bonjour
Je viens de faire un petit test dans W10, sur SSD, XnView installé dans C:\Programmes: première ouverture du programme normale, rapide.
J' ai désinstallé proprement XnViewMP, puis réinstallé la version 0.92 avec toutes options par défaut (donc .ini et .db dans dossier utilisateur sur le SSD), sauf dossier d' installation dans E:\Programmes, qui se trouve sur un HDD: premier démarrage 8 secondes...
Mes précédentes installation avaient .ini et .db dans le dossier Xnview, et j' avais un délai similaires.
Je viens aussi de re tester Google earth installé dans E:\ avec dossier temporaire sur D:\ (aussi sur HDD): splash screen en 3-4 secondes, la fenêtre apparait presque aussitôt après.