0.98: Multiselect - wrong preview

Bugs which have been reproduced by a second user or the developer, or features to do

Moderator: Dreamer

Post Reply
MacSass
Posts: 6
Joined: Sat May 20, 2017 5:56 pm

0.98: Multiselect - wrong preview

Post by MacSass »

XnView: MP 0.98 - 64 bit
OS: Windows - 64bit

When doing a multi-select of serveral thumbnails at once by doing a click + hold-shift-click then the preview on second click does not show the picture that was actually clicked (last thumb selected) but it shows the first picture of the second row of the selection.
Not a major issue - but surely not intended behaviour.
When you then "move backwards" (still holding shift key) to change the selection, the behaviour is as expected (last picture of selection shown in preview windows). When you "move forward" further down again, the wrong behaviour is showing again.

Effect: <Different picture in preview window than expected.>

To reproduce:
1. Open a folder with several pictues
2. click on image - it is shown in preview windows
3. Hold shift and click on image further down some rows ... preview shows first picture of second selected row, instead of last picture


Expected behaviour: Always show last picture clicked of a selection.

See attachement for more detailed explanation ...

Regards and thanks for the great piece of software - MacSass
Attachments
2021-01-10 16_56_02-Window.png
MacSass
Posts: 6
Joined: Sat May 20, 2017 5:56 pm

Re: 0.98: Multiselect - wrong preview

Post by MacSass »

Issue still current for 0.98.1.

Regards - MacSass
User avatar
xnview
Author of XnView
Posts: 35262
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98: Multiselect - wrong preview

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.
MacSass
Posts: 6
Joined: Sat May 20, 2017 5:56 pm

Re: 0.98: Multiselect - wrong preview

Post by MacSass »

Issue still current in 0.98.3 unfortunately ... too low priority :wink:
Post Reply