0.78: colour labels do not always refresh in browser

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
Alt Bass
Posts: 23
Joined: Mon May 30, 2011 2:55 pm

0.78: colour labels do not always refresh in browser

Post by Alt Bass » Thu Mar 17, 2016 3:22 pm

Colour labels in browser do not update after assigning new labels in viewer. Probably: after viewing part of files in folder using selection.

Reproducible: from time to time, no specific way.

Windows 7 x64 SP1 0.78 x64 installable

Alt Bass
Posts: 23
Joined: Mon May 30, 2011 2:55 pm

Re: 0.78: colour labels do not always refresh in browser

Post by Alt Bass » Thu Mar 17, 2016 5:59 pm

It also seems that colour labels do not refresh if images are opened from quick search results.

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.78: colour labels do not always refresh in browser

Post by xnview » Fri Mar 18, 2016 8:03 am

Alt Bass wrote:Colour labels in browser do not update after assigning new labels in viewer. Probably: after viewing part of files in folder using selection.
right a known issue
Pierre.

User avatar
helmut
Posts: 8145
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.78: colour labels do not always refresh in browser

Post by helmut » Tue Mar 14, 2017 3:14 pm

xnview wrote:
Alt Bass wrote:Colour labels in browser do not update after assigning new labels in viewer. Probably: after viewing part of files in folder using selection.
right a known issue
@Pierre: What is the status of this problem/issue? Has this been resolved?

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.78: colour labels do not always refresh in browser

Post by xnview » Thu Mar 16, 2017 3:10 pm

for me resolved
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1491
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.78: colour labels do not always refresh in browser

Post by m.Th. » Thu Mar 16, 2017 4:44 pm

xnview wrote:for me resolved
In the case of JPG (and probably other formats which support metadata embedding): yes
In the case of CR2 (and probably other formats which DO NOT support metadata embedding): no

:)
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
xnview
Author of XnView
Posts: 30024
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.78: colour labels do not always refresh in browser

Post by xnview » Fri Jun 09, 2017 1:40 pm

m.Th. wrote:In the case of CR2 (and probably other formats which DO NOT support metadata embedding): no
could you describe how to reproduce?
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1491
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.78: colour labels do not always refresh in browser

Post by m.Th. » Tue Jun 13, 2017 9:35 am

xnview wrote:
m.Th. wrote:In the case of CR2 (and probably other formats which DO NOT support metadata embedding): no
could you describe how to reproduce?
1. Double-click on a JPG (it will open in a new tab - in Viewer)
2. Go to the new tab and press Ctrl+1 and/or (optionally) Ctrl+Sh+1 (a red star and (optionally) circle will appear in the top right corner)
3. Go back to browser. You will see on the selected thumb the same red star and (optionally) the red circle
4. Double-click on a CR2
5. Go to the new tab and press Ctrl+1 and/or (optionally) Ctrl+Sh+1 (a red star and (optionally) circle will appear in the top right corner)
6. Go back to Browser

Expected: I must see on the selected thumb the same red star and (optionally) the red circle

Actual: I see nothing.
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

Chipmunk13
Posts: 2
Joined: Fri Mar 30, 2018 8:55 am

Re: 0.78: colour labels do not always refresh in browser

Post by Chipmunk13 » Fri Mar 30, 2018 9:34 am

Hi, I am having the same problem, I'm using Jpegs, Windows 10 Pro.

> I double click on an image, opens in a new tab/viewer, quickly scroll through, rating as I go.
> Close tab/viewer, select all rated in Browser, right click, open.
> Scroll through all rated and assign colour labels to each.
> Close tab/viewer, select rated + colour - Nothing in view.
> Close and relaunch XnView, rated and coloured images in view.

Is there a way to do this without having to close the program?

Thank you - it is an absolutely fantastic addition to my workflow other than that :)

Post Reply