Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Moderators: XnTriq, helmut, cday, xnview, Dreamer

Post Reply
FeriM
Posts: 5
Joined: Fri Nov 24, 2017 7:32 pm

Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by FeriM » Fri Nov 24, 2017 7:56 pm

Subject: 0.88: <Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180>

XnView: MP 0.88 - 64 bit
OS: Windows 64bit

<Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180.>

Effect: <Thumbnail and Image Orientation out of sync >

To reproduce:
1. Consider a Jpeg having a rotation of bottom-right (3) in Orientation, both for Image and Thumbnail
2. Browser->Jpeg lossless transformation->Rotate 180 (or make a Reset EXIF Orientation Field)
3.
Actual behaviour (bug): <Current wrong behaviour of XnView> :bug:
The EXIF Orientation tag for Image is set to top-left (1) , but the EXIF Orientation tag for Thumbnail remains bottom-right (3)

Expected behavior:
I would expect the Orientation for the Thumbnail to be synced to the Orientation for the Image (like it happens when rotating to 90).
After this operation, even using Metadata->EXIF Thumbnail Rebuild does not change the Thumbnail Orientation tag to match the orientation of the image.
I am not sure where the Orientation tag for the Thumbnail is used so I cannot see implications further.

User avatar
xnview
Author of XnView
Posts: 29471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by xnview » Sat Nov 25, 2017 9:50 am

please send me the jpeg used?
Pierre.

FeriM
Posts: 5
Joined: Fri Nov 24, 2017 7:32 pm

Re: Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by FeriM » Sun Nov 26, 2017 1:16 am

http://picpaste.com/DSC_0007-pYkG0Dvs.JPG

Just to make it clear... the picture and the thumbnail are not displayed with opposite orientation after the operation, but the Thumbnail Orientation flag and the Image Orientation flag do not match after the operation.
Actually the same thing happens on other operations like resize.

User avatar
xnview
Author of XnView
Posts: 29471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by xnview » Sun Nov 26, 2017 12:47 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
picture
Pierre.

User avatar
xnview
Author of XnView
Posts: 29471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by xnview » Sun Apr 22, 2018 8:34 am

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 29471
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Thumbnail and Image Orientation out of sync after Jpeg Lossless Rotate to 180

Post by xnview » Thu Jun 07, 2018 9:41 am

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.

Post Reply