0.96.2 - Issue moving a category through Edit > Parent

Bugs which have been reproduced by a second user or the developer, or features to do

Moderator: Dreamer

Post Reply
Gwenael Q.
Posts: 75
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Issue : "Edit... > Parent" command (Categories pane) doesn't allow some moves that shoul be allowed.

To reproduce:

1. In the Categories pane (View > Data pane > Categories), create a category "testing" then a subcategory "subcateg" then a sub-subcategory "categ1" (resulting "path" : "testing|subcateg|categ1"
2. Create, elsewhere (= not under "testing"), an other category "categ1".
3. right-click on it > Edit.. > Parent then choose "testing"
4. Message error "This parent is already a child of current category"

Expected behavior :

XnviewMP should not raise an error and should have moved "categ1" under "testing" with "testing" having now the following structure :

Code: Select all

- testing
   - categ1
   - subcateg
       - categ1

XnViewMP 0.96.2 - 64 bit on Windows 8.1 64bit

Thank you for listening
User avatar
xnview
Author of XnView
Posts: 34681
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.
Gwenael Q.
Posts: 75
Joined: Mon Apr 06, 2020 2:06 am
Location: Martinique

Re: 0.96.2 - Issue moving a category through Edit > Parent

Post by Gwenael Q. »

Hello,

Replicated with XnviewMP 0.97.0 x64 (win 8.1 x64)

Please note that this issue also deals with the "Parent" command

Thank you for listening
Post Reply