0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

User avatar
masterjp
Posts: 51
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf (Germany)

0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby masterjp » Mon Jul 10, 2017 8:32 am

I enabled the catalog function in the settings menue. Sometimes XnView MP switch the checkbox automatically off. I do not know why.
CPU: Intel i5 3570k | Mainboard: ASUS P8Z77-V | RAM: 16 GB - DDR3 - 2.133 Mhz | Samsung SSD 850 Pro 256 GB
OS: Windows 10 Pro x64 & all updates
XN-View 2.43 x86 | XN-View MP 0.87 x64 | Adobe Photoshop Elements 15 x64

cday
XnThusiast
Posts: 1588
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby cday » Mon Jul 10, 2017 8:49 am

masterjp wrote:I enabled the catalog function in the settings menu. Sometimes XnView MP switch the checkbox automatically off. I do not know why.

Is the setting possibly being lost when XnView MP is closed?

User avatar
xnview
Author of XnView
Posts: 28386
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby xnview » Mon Jul 10, 2017 12:48 pm

Strange, do you reproduce it?
Pierre.

cday
XnThusiast
Posts: 1588
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby cday » Mon Jul 10, 2017 1:07 pm

xnview wrote:Strange, do you reproduce it?

If Enable Catalog is de-selected, and then the program is closed, when the program is reopened it is selected again...

That seems unintended, but the selected state does seem to persist when the program is closed and reopened.

So no direct insight into masterjp's reported problem of the setting sometimes being lost...

User avatar
masterjp
Posts: 51
Joined: Fri Feb 13, 2009 4:37 pm
Location: Duesseldorf (Germany)

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby masterjp » Mon Jul 10, 2017 1:48 pm

The problem of the enabled and disabled checkbox for "enable catalog" exists.

I enabled the catalog function, closed XnView MP and restarted it again.
The checkbox "enable catalog" was disabled. Then I closed XnView MP and started it again two times.
After that the "enable catalog" checkbox was activated. - Very strange.

I use registry for XnView MP settings.

Maybe the "enable catalog" state is not saved correctly in the registry?
CPU: Intel i5 3570k | Mainboard: ASUS P8Z77-V | RAM: 16 GB - DDR3 - 2.133 Mhz | Samsung SSD 850 Pro 256 GB
OS: Windows 10 Pro x64 & all updates
XN-View 2.43 x86 | XN-View MP 0.87 x64 | Adobe Photoshop Elements 15 x64

User avatar
xnview
Author of XnView
Posts: 28386
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby xnview » Mon Jul 10, 2017 1:57 pm

right, will be fixed in beta 2
Pierre.

cday
XnThusiast
Posts: 1588
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.87 beta 1 - Settings->Enable Catalog automatically switch off?

Postby cday » Mon Jul 10, 2017 2:01 pm

masterjp wrote:I enabled the catalog function, closed XnView MP and restarted it again.
The checkbox "enable catalog" was disabled. Then I closed XnView MP and started it again two times.
After that the "enable catalog" checkbox was activated. - Very strange.

I use registry for XnView MP settings.

Maybe the "enable catalog" state is not saved correctly in the registry?

I'm testing using the ZIP version with the ini file in Program (XnView), and Catalog is always enabled when the program is started, even if it was selected off when the program was closed...


Return to “Retest”

Who is online

Users browsing this forum: No registered users and 1 guest