Page 1 of 1

Operation "Move to" opens wrong dialogue

Posted: Mon Jan 22, 2018 7:03 am
by josedumoretzsohn
After selecting a few images, and commanding "Create Shortcut", the usual dialogue appears with the Folders to be reached. However, after clicking on the destination folder, a "strange" second dialogue appears asking whether I want to overwrite the images, one or all. This second dialogue is unnecessary, because the images moved are entirely new to the destination folder.

Re: Operation "Move to" opens wrong dialogue

Posted: Mon Jan 22, 2018 11:36 am
by xnview
could you describe the way to reproduce?

Re: Operation "Move to" opens wrong dialogue

Posted: Fri Jan 26, 2018 7:14 am
by m.Th.
1. Can you give screenshots + steps?
2. If you change the destination folder (for ex. make a new one), the problem persists?
3. What versions XnV MP/OS do you have?

Re: Operation "Move to" opens wrong dialogue

Posted: Wed Jan 31, 2018 12:04 am
by josedumoretzsohn
xnview wrote:could you describe the way to reproduce?
I did not understand your question? The bug is precisely the "opening of this second dialogue" (Replace/With: that usually only opens when there is/are image/images to be replaced), because the destination folder is empty, there is nothing to be replaced there.

Re: Operation "Move to" opens wrong dialogue

Posted: Wed Jan 31, 2018 12:41 am
by josedumoretzsohn
m.Th. wrote:1. Can you give screenshots + steps?
2. If you change the destination folder (for ex. make a new one), the problem persists?
3. What versions XnV MP/OS do you have?
Describing:
My version is XNView MP 0.89.
Steps:
1) In my Folder \zzCAPTURE\ there are 4 images, and I will create shortcuts to \zzEDIT\, which is empty
2) I select the 4 images, right-click on Create Shortcut. The shortcuts are printed on the \CAPTURE\ folder.
3) I select the shortcuts and command "Move To", either on its icon or typing ALT+M. The regular MOVE TO dialogue opens.
4) When II select the destination folder \EDIT, which is empty, the REPLACE/WITH dialogue opens.
5) The opening of the REPLACE/WITH dialogue is the bug itself, because the destionation folder is empty.

I can send screenshots; in fact, I created them, but don't know how to send them. I tried to, clicking on the IMG button above the Text Box, but it did not open my Folder Manager.

Re: Operation "Move to" opens wrong dialogue

Posted: Wed Jan 31, 2018 12:58 am
by josedumoretzsohn
Just to add: if I OK the second (buggy) dialogue, the operation of MOVE TO (or COPY TO) succeeds; If I CANCEL this dialogue, the images stay where they are.
josedumoretzsohn wrote:
m.Th. wrote:1. Can you give screenshots + steps?
2. If you change the destination folder (for ex. make a new one), the problem persists?
3. What versions XnV MP/OS do you have?
Describing:
My version is XNView MP 0.89.
Steps:
1) In my Folder \zzCAPTURE\ there are 4 images, and I will create shortcuts to \zzEDIT\, which is empty
2) I select the 4 images, right-click on Create Shortcut. The shortcuts are printed on the \CAPTURE\ folder.
3) I select the shortcuts and command "Move To", either on its icon or typing ALT+M. The regular MOVE TO dialogue opens.
4) When II select the destination folder \EDIT, which is empty, the REPLACE/WITH dialogue opens.
5) The opening of the REPLACE/WITH dialogue is the bug itself, because the destionation folder is empty.

I can send screenshots; in fact, I created them, but don't know how to send them. I tried to, clicking on the IMG button above the Text Box, but it did not open my Folder Manager.

Re: Operation "Move to" opens wrong dialogue

Posted: Wed Jan 31, 2018 4:15 am
by XnTriq
josedumoretzsohn wrote:I can send screenshots; in fact, I created them, but don't know how to send them. I tried to, clicking on the IMG button above the Text Box, but it did not open my Folder Manager.
Please refer to cday's tutorial on how to add attachments to a post.

Re: Operation "Move to" opens wrong dialogue

Posted: Thu Feb 01, 2018 6:09 pm
by josedumoretzsohn
The screenshots follow:
1) 01-Destinatio Folder Empty.jpg
2) 01_SourceFolder.jpg
3) 02-Selection-to-Create-Shortcut.jpg
4) 03-Create-Shortcut.jpg
5) 04-MoveTo-Icon.jpg
6) 05-MoveTo-Dialogue.jpg
7) 06-Replace-With-Dialogue-Opens.jpg
07-Replace-With-Dialogue-Opens.jpg
07-Replace-With-Dialogue-Opens.jpg (95.31 KiB) Viewed 1026 times
XnTriq wrote:
josedumoretzsohn wrote:I can send screenshots; in fact, I created them, but don't know how to send them. I tried to, clicking on the IMG button above the Text Box, but it did not open my Folder Manager.
Please refer to cday's tutorial on how to add attachments to a post.

Re: Operation "Move to" opens wrong dialogue

Posted: Thu Apr 12, 2018 9:06 am
by josedumoretzsohn
I tentatively installed the 0.90 .zip version, but the bug persists.

Re: Operation "Move to" opens wrong dialogue

Posted: Fri Apr 20, 2018 3:34 pm
by xnview
See issue for current status and some details.

Re: Operation "Move to" opens wrong dialogue

Posted: Thu Jun 07, 2018 9:42 am
by xnview
This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.