2.34:Multiple shots per second are displayed out of sequence

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

JeanGoulet
Posts: 8
Joined: Tue Jan 26, 2010 5:27 am

2.34:Multiple shots per second are displayed out of sequence

Postby JeanGoulet » Mon Nov 09, 2015 3:03 am

I use Xnview all the time, it's great. But for burst mode photos (multiple shots per second), it doesn't sort well. This means a fantastic sequence of photos is sometimes out of sequence and makes no sense.

I downloaded the latest Xnview for windows 7, 2.34, and saw that this problem has not been resolved.

To observe this problem:
- set your camera to a fast burst mode (in my case, Panasonic Lumix FZ1000 that can do 50 fps)
- take a few seconds of photos (e.g. with a moving object left to right)
- load them in XnView
- Set it up like this: View -> Sort by -> EXIF date, ascending

The resulting photos are not all in order. This makes for a headache situation.

There are multiple photos taken in the same second as seen in the EXIF date information. But XnView is ignoring key information that would display them in the proper order:
1) the sequence number in the EXIF data (first photo is 1, next is 2, etc.)
2) the number of the filename itself (IMG5247, IMG5248, etc.)

Question: Is there an existing method that solves this problem? If not, may I suggest implementing a sort algorithm that considers a second sort key (1 or 2 above) automatically, so that nobody expériences this problem any more.

Thanks to anybody who can help on this.

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Multiple shots per second are displayed out of sequence

Postby xnview » Mon Nov 09, 2015 10:39 am

could you send me some samples file, so i'm able to reproduce this problem?
Pierre.

JeanGoulet
Posts: 8
Joined: Tue Jan 26, 2010 5:27 am

Re: Multiple shots per second are displayed out of sequence

Postby JeanGoulet » Tue Oct 18, 2016 4:33 am

xnview wrote:could you send me some samples file, so i'm able to reproduce this problem?


Ok I tried the latest xnview (v2.37) in Win10 in the hopes maybe this was fixed now. But unfortunately it is not. The photos are still shown out of sequence when sorted by EXIF date.

So I have located a photo sequence which demonstrates the problem clearly in xnview.

I made a summary screenshot, to shows the filenames at the bottom (they are not in the expected sequence): https://goo.gl/photos/jkCaxkSNwd189S6U7

I have made a shared album for you with the actual photos, complete with EXIF information, to reproduce the problem. I have sent you the link by email.

When you load that page, you will be able to:
- See big thumbnails of the 50 photos
- At the top right there is the icon for options (3 dots) which has "download all"
- Use that to get photos.zip with the 50 photos
- Unzip to your PC and load with XnView

To show the problem: View -> Sort by -> EXIF date, ascending (result: Some strange out of sequence sorting occurs. Note XnView picked P1180215.JPG first, even though the EXIF sequence field = 4 for that one (instead of the expected P1180183.JPG which has sequence=1).

The photos themselves really are in sequence and this can be proven by the following setting: View -> Sort by -> name, ascending (result: Perfectly in sequence, because the names happen to be in sequence. Unfortunately this setting is of no use to me because I rename the best photos myself and so I cannot rely anymore on the camera's choice of filename).

Presumably, everybody who does fast bursts with a camera is prone to this very same problem in XnView.

May I suggest implementing a sort algorithm that automatically considers a second sort key (sequence number in the EXIF data), so that nobody experiences this problem any more. Thanks so much!

User avatar
xnview
Author of XnView
Posts: 28275
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Multiple shots per second are displayed out of sequence

Postby xnview » Thu Oct 20, 2016 8:53 am

ok, i confirm the bug
Pierre.

JeanGoulet
Posts: 8
Joined: Tue Jan 26, 2010 5:27 am

Re: 2.34:Multiple shots per second are displayed out of sequ

Postby JeanGoulet » Thu Oct 20, 2016 4:23 pm

Regarding the burst shots coming within the same second of "EXIF date", I did a bit more research to see what EXIF fields are available depending on what camera produced the EXIF information.

I know the Panasonic Lumix FZ1000 (such a great camera!) and Canon (PowerShot SX1) both use: Sequence number (starts at 1 and goes up)

and according to this web page (http://agateau.com/2012/oups-my-burst-s ... l-shuffled) it says Nikon uses ImageCount

Since it appears there is no standard between companies, a generic and future-proof solution for XnView would be to let the user decide whichever EXIF field is pertinent to solve the sorting problem.

Here are two ideas:

- Add a new setting in XnView options: "Select 2nd sort tag for EXIF date"
> the user types in a keyword; like "sequence number" or selects from a drop-down list. If the keyword is not found in the EXIF, it should use the filename.

- A more sophisticated solution could be provided in XnView options: It would be to detect the manufacturer via EXIF, then identify the "burst shot counter" keyword appropriately
> this method could be appear as "smart autodetect", and the user could select that. Useful when dealing with photos coming from multiple cameras.

JeanGoulet
Posts: 8
Joined: Tue Jan 26, 2010 5:27 am

Re: 2.34:Multiple shots per second are displayed out of sequence

Postby JeanGoulet » Mon Jul 31, 2017 3:09 am

SO HAPPY! I can confirm that the bug is fixed for the Panasonic Lumix FZ1000!

And the timing is perfect because I just got home from 1200 photos taken this afternoon at the Montreal Formula E event, and decided to check for any XnView updates.

So I installed it and viewed photos of the race cars at full speed, and was DELIGHTED to see that each frame is shown in the expected order.

Then I looked at the readme.txt which said: * Sort by exif - viewtopic.php?f=36&t=32387

This is a message of thanks for all the developers who continue to perfect XnView by taking the time to read user's input and come up with solutions.

By the way, out of curiosity, was "sort by exif" fixed by making use of the field "Sequence number" in the EXIF data?


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 0 guests