0.84: Artefacts when high quality zooming 4-color greyscale

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
helmut
Posts: 8138
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.84: Artefacts when high quality zooming 4-color greyscale

Post by helmut » Mon Mar 06, 2017 8:10 pm

XnView: MP 0.84
OS: Windows 10 - 64 bit

When high quality zooming into a 4-color greyscale image you will see artefacts even though the original image is completely white.

Effect: Unexpected behaviour

To reproduce:
1. Download and save the attached PNG image file.
2. Open the PNG image file in XnView's viewer (View mode).
Please note that the image doesn't contain anything and is completely white. (correct)
3. Convert the image to a 4-colour greyscale image (Image » Change Colour depth). When converting, don't use any dithering ("None").
4. Select "Zoom in" for "High zoom quality" in Tools » Settings | View | View.
5. Zoom slowly into the image
Actual behaviour (bug): When zooming into the white image you see a "grid" of black pixels at 200%, 400%, 800%, and 1600%. :bug:

Expected behaviour: When zooming into a white image you should see white - nothing else.

Note: The problem might be related to 0.84: Crash when high quality zooming b/w image.
Attachments
white_blank.png
white_blank.png (3.05 KiB) Viewed 374 times

User avatar
helmut
Posts: 8138
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Artefacts when high quality zooming 4-color greysc

Post by helmut » Fri Mar 10, 2017 4:00 pm

Could someone please try to reproduce the problem?

User avatar
XnTriq
Moderator & Librarian
Posts: 5267
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.84: Artefacts when high quality zooming 4-color greysc

Post by XnTriq » Fri Mar 10, 2017 8:30 pm

helmut wrote:When zooming into the white image you see a "grid" of black pixels at 200%, 400%, 800%, and 1600%. :bug:
Confirmed :bugconfirmed:

Related bug in XnView Classic: Faint grid overlayed on high quality downsampled view

User avatar
helmut
Posts: 8138
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Artefacts when high quality zooming 4-color greysc

Post by helmut » Fri Mar 10, 2017 8:58 pm

Thank you for confirming, XnTriq.

:arrow: Reproduced

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Artefacts when high quality zooming 4-color greyscale

Post by xnview » Sat Jun 17, 2017 5:02 pm

O.k., thank you, I can also reproduce the problem. Issue 1237 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 29744
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Artefacts when high quality zooming 4-color greyscale

Post by xnview » Sat Jul 08, 2017 12:55 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5267
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.84: Artefacts when high quality zooming 4-color greyscale

Post by XnTriq » Fri Aug 18, 2017 2:45 am

Tested in 0.87 beta 3: Fixed!

Post Reply