Selected Image Loses Focus

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
antialias
Posts: 2
Joined: Thu Dec 07, 2017 11:42 pm

Selected Image Loses Focus

Post by antialias »

Hi, in the MP version, once you select (click on) an image, you can then navigate image thumbnails by pressing the directional arrows.

However, every time you use the mouse scroll wheel to zoom in or out the selected image loses focus.
It forces me to visually locate the image I was on then click on it just to continue navigating images.

This behavior is NOT in XnView, this only happens in the MP version. Heck, in the original version, it almost impossible to lose focus unless you click in the white space. For this reason, I'm thinking it may be bug?

Is this behavior intentional by design? I'm hoping it's a setting that I'm missing, but I've tried to no avail.
Thank you!
antialias
Posts: 2
Joined: Thu Dec 07, 2017 11:42 pm

Re: Selected Image Loses Focus

Post by antialias »

Sorry, I just read the helpful reminder post *** Reporting a bug: HowTo and Template ***

1. The setup is View/View As/Thumbnails
2. The Layout is Layout 2
3. If you click on the thumbnail, the image has focus, you can navigate normally.
4. If you hover over the Preview image, mouse scroll to zoom in a bit, you will LOSE focus on the thumbnail, forcing you to re-select it in order to keep navigating.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Selected Image Loses Focus

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Selected Image Loses Focus

Post by xnview »

See issue for current status and some details.
Pierre.
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Selected Image Loses Focus

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.91. Please check and confirm the bug fix here.
Pierre.
HanVroon
Posts: 211
Joined: Thu Jan 28, 2010 7:30 am

Re: Selected Image Loses Focus

Post by HanVroon »

Tested with 0.91 beta 4, fixed.

Reproduced with 0.90:
Choosen layout with browser and preview.
Selected a thumbnail. Used the arrow-right to move to the nex thumb, that worked.
Moved the mouse to the preview.
Zoomed in the preview.
Used the arrow-right, the zoomed area in the preview moved, not the next thumb was selected.

Tested with 0.91 beta 4:
Choosen layout with browser and preview.
Selected a thumbnail. Used the arrow-right to move to the nex thumb, that worked.
Moved the mouse to the preview.
Zoomed in the preview.
Used the arrow-right, the next thumb was selected.
Post Reply