XnView MP hangs when folder contains MP4 files

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
mauri
Posts: 1
Joined: Sun Oct 21, 2018 5:39 pm

XnView MP hangs when folder contains MP4 files

Post by mauri » Sun Oct 21, 2018 6:09 pm

Hi all

I have a problem with XnView 0.92 (and also 0.91) with MP4 files being generated by my Lumix GX80 camera.
The MP4 files are pictures taken with the "post focus" feature (https://www.panasonic.com/global/consum ... focus.html).

Showing the folder content works when opening XnView MP if the folder contains any MP4 post focus pictures.
The preview is shown in the preview window.
When doing any operation in the detail view (e.g. reordering the pictures, deleting a pciture) XnView MP freezes immediately and never comes back.
The bug can be reproduced easily (see attached gif).

When I remove all MP4 pictures from the folder then XnView MP works as expected and doesn't freeze.

Attached is a link to the problematic MP4 file (https://we.tl/t-Fv8BVZcp8v) and an animated gif showing the bug.

Environment: Windows 10 64bit
Language: German

Please let me know if you need any additional information.
Thanks for your help in advance.

Regards
M. Erni
Attachments
2018-10-21_20-01-32.gif

dihei1955
Posts: 2
Joined: Thu Jun 21, 2018 6:47 am

Re: XnView MP hangs when folder contains MP4 files

Post by dihei1955 » Sun Nov 11, 2018 4:00 pm

Hi,
I have the same problem. Not all MP4-files let hang XnView MP but some special.
That problem occured with the SourceForge-Program 'Mp4Video 1-click' because it used an old ffmpeg version. When I replaced that with the actual version the problem was solved.
XnView MP shows that hanging with all MP4 that the old 1-click could not convert. Unfortunately it hangs with fresh converted videos nevertheless :(

dihei1955
Posts: 2
Joined: Thu Jun 21, 2018 6:47 am

Re: XnView MP hangs when folder contains MP4 files

Post by dihei1955 » Sun Nov 11, 2018 9:37 pm

Hi,
the problem is not the format of the video - it's the 4-thumbnail-view for videos with short ones. Changing the setting back to 1 image in the thumbnail solves the problem, xnview does not freeze anymore and shows the thumbnail.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: XnView MP hangs when folder contains MP4 files

Post by Tehbotol » Thu Nov 22, 2018 3:36 pm

Thank you for this, Definitely have the same problem, xnviewmp suddenly hangs and the window show not responding (while loading the thumbnail for the directory), Windows 10 x64, Xnviewmp 64bit v0.92

i though it was my external drive that are dying, then later the internal ssd have this issue too, and then i find it was a video that seem to have this issue and seem not all mp4 have this issue,

turning off the 4 thumbnail view for video solve this issue

don't know why this issue hasn't fixed yet as it seem it also occur in previous version

thanks again
dihei1955 wrote:
Sun Nov 11, 2018 9:37 pm
Hi,
the problem is not the format of the video - it's the 4-thumbnail-view for videos with short ones. Changing the setting back to 1 image in the thumbnail solves the problem, xnview does not freeze anymore and shows the thumbnail.

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP hangs when folder contains MP4 files

Post by xnview » Tue Dec 18, 2018 1:07 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: XnView MP hangs when folder contains MP4 files

Post by Tehbotol » Tue Dec 25, 2018 12:18 pm

seem turning off the 4 thumbnail view, only fixed some folder,
as i still have several videos (including mov file) that cause xnview to hangs (not responding) when creating the SINGLE thumbnail

i have send the problematic video to your pm thanks

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP hangs when folder contains MP4 files

Post by xnview » Thu Jan 31, 2019 1:49 pm

This problem is supposed to be fixed in XnView MP 0.93. Please check and confirm the bug fix here.
Pierre.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: XnView MP hangs when folder contains MP4 files

Post by Tehbotol » Fri Apr 12, 2019 11:59 am

nope it still hang (xnview not responding) with video with short duration (1-3 second mp4 video)

disabling the 4 thumbnail in videos fixed the issue,
seem the issue is xnview can't create 4 thumbnail in a short duration video causing it to crash.

using 0.93.1 x64 in windows 10 x64

User avatar
xnview
Author of XnView
Posts: 31918
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP hangs when folder contains MP4 files

Post by xnview » Mon Apr 15, 2019 12:06 pm

Tehbotol wrote:
Fri Apr 12, 2019 11:59 am
nope it still hang (xnview not responding) with video with short duration (1-3 second mp4 video)

disabling the 4 thumbnail in videos fixed the issue,
seem the issue is xnview can't create 4 thumbnail in a short duration video causing it to crash.

using 0.93.1 x64 in windows 10 x64
could you send me a video link?
Pierre.

Tehbotol
Posts: 17
Joined: Thu Nov 22, 2018 3:28 pm

Re: XnView MP hangs when folder contains MP4 files

Post by Tehbotol » Mon Apr 15, 2019 11:12 pm

pm sent thanks

also not a bug but a feature request, would it be possible for xnview to detect all black or all whites thumbnail when creating thumbnail and skip the frame until a image show up? since there's many video that start with black frame for few second in the start or in the end
xnview wrote:
Mon Apr 15, 2019 12:06 pm
Tehbotol wrote:
Fri Apr 12, 2019 11:59 am
nope it still hang (xnview not responding) with video with short duration (1-3 second mp4 video)

disabling the 4 thumbnail in videos fixed the issue,
seem the issue is xnview can't create 4 thumbnail in a short duration video causing it to crash.

using 0.93.1 x64 in windows 10 x64
could you send me a video link?

RandElement
Posts: 1
Joined: Sat Aug 31, 2019 6:39 am

Re: XnView MP hangs when folder contains MP4 files

Post by RandElement » Sat Aug 31, 2019 7:12 am

Hi!

The problem still exists.
Try this (https://www.mediathek.at/portaltreffer/ ... pool/BWEB/) file with the help of the firefox addon "VideoDownloadHelper". In this example this is only an audio file in mpeg format. But the problem is still there with other MPGs. Unfortunately I can't find other examples on my PC because I converted them.
Here is a link to "my" download of the example above: https://we.tl/t-6f84cuNVgc but this link works only the next 7 days. Send me a pm if you need my file again.
btw: this bug exists since many years. I am not sure but I think in the non MP-version of XnView too which I used a long time. For me it was not a big problem because the "buged" files are rarely.

Have a great day and thx for the existance of XnView!
R.

Post Reply