Script conversion XBS: Changing after saving

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Peter2
XnThusiast
Posts: 1111
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Script conversion XBS: Changing after saving

Post by Peter2 » Mon May 11, 2009 9:17 am

:bug:
I define a conversion with

Code: Select all

- change canvas to 145%, centered, white background
- [b]save to TIF[/b]
- keep date and time
- overwrite / replace
Then I "save as ..." xbs - file and start the script - and get JPG-Files.

Then I select my script from the list and start it - and it works fine (TIF).

Then I change something in the configuration, save it to my script, start it - and get JPG-Files....

Seem to be a bug .. :bug:

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

User avatar
Peter2
XnThusiast
Posts: 1111
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Re: Script conversion XBS: Changing after saving

Post by Peter2 » Wed May 13, 2009 6:45 pm

Anyone who can confirm or disprove this behaviour?

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Script conversion XBS: Changing after saving

Post by marsh » Wed May 13, 2009 6:51 pm

Peter2 wrote:Anyone who can confirm or disprove this behaviour?

Peter
Save resets format for me too.

User avatar
Peter2
XnThusiast
Posts: 1111
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Re: Script conversion XBS: Changing after saving

Post by Peter2 » Sat Jul 18, 2009 7:37 pm

At the moment I can not test it, so -
is this bug fixed?

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

User avatar
Peter2
XnThusiast
Posts: 1111
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Re: Script conversion XBS: Changing after saving

Post by Peter2 » Mon Aug 03, 2009 10:45 am

In this feature seem to be a bug greater then it seems at the first moment.

I set it to "Save as TIF" - my XBS contains:

Code: Select all

canvas( 0 3307 4677 6 255 255 255 0 )
settings( 0 0 1 0 1 0 )
output( jpeg 80 0 0 0 0 0 1 )
I set it to "Save as Kodak Cineon" - my XBS contains:

Code: Select all

canvas( 0 3307 4677 6 255 255 255 0 )
settings( 0 0 0 0 0 0 )
output_path( D:\D-TEMP )
output( ÿÿÿÿ*ˆA~À´A~  )
Sometimes, when enabling the option "Use original path", the "directory" is disbaled, sometimes it is not disabled.

And when I save a "difference canvas", I get this:

Code: Select all

canvas( 0 #-400 #0 6 255 255 255 0 )
settings( 3 0 1 0 1 0 )
output( tiff 2 6 0 )
This seem to be OK, but if I load this file, I get crazy values in my dialogue.

Please check it, Pierre.

Thanks.

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

User avatar
XnTriq
Moderator & Librarian
Posts: 5424
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Script conversion XBS: Changing after saving

Post by XnTriq » Mon Aug 03, 2009 8:00 pm


User avatar
Peter2
XnThusiast
Posts: 1111
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Re: Script conversion XBS: Changing after saving

Post by Peter2 » Mon Aug 03, 2009 8:33 pm

That's a long list of posting, and today I added some more. It seem that there are two problems

- real bugs (mixture of read and write the files versus standard settings - sometimes it is not clear what should be refreshed or not)
- user defined handling (should it go back to standard or not?)

I think the second question could be solved with an additional dialogue:
The users makes his settings (by loading XBS or clicking) - he starts the software - the software displays the converting dialogue "File 3 of 25; 8%" (already done) - the converting dialogue ends with the question
"Do you want to
restore standard settings /
restore active settings /
quit the dialogue?"


This coulkd help for second problem.

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

Post Reply