problem with Aero theme

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
anonymous_user

problem with Aero theme

Post by anonymous_user » Wed Jul 16, 2008 3:45 pm

When in browser mode or when viewing an image, and XnView is maximized there is this strange border on the right-side.

Vista Basic:

Image

Aero:

Image[/url]


anonymous_user

Post by anonymous_user » Thu Jul 17, 2008 5:56 am

Ok I will do a search next time Image

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Thu Jul 17, 2008 7:31 am

anonymous_user wrote:Ok I will do a search next time Image
Yes, searching first is a very good idea.

BTW:
Your animated GIF is quite nice and probably adequate and useful in many situations. ;-)

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Win 7 64bit

Post by GeorgD » Mon Oct 26, 2009 11:37 pm

In Win 7 64bit RC1 german, I also have the grey area at right border in viewer & browser. It is as high as the image is shown and exactly 2px wide. It's not hurting but a little irritating 8) Here it happens in XnView 1.96.5 and also 1.82.

Here, on mouseover the cursor does not change to horizontal arrow like in [-1.91] Problem with maximized browser window on Vista. Also, turning ON "Disable display scaling on high DPI settings" in Properties|Compatibility for xnview.exe did not help on my system :-( (same suggestion is in XnView and Vista - 2 little things)

I can confirm that WinMerge 2.12.4.0 has the same problem, it happens with Aero standard theme and XnView window is maximized, like stated in 1.91.6: Not full screen window in Vista.
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

User avatar
xnview
Author of XnView
Posts: 31597
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Win 7 64bit

Post by xnview » Tue Oct 27, 2009 8:52 am

GeorgD wrote:In Win 7 64bit RC1 german, I also have the grey area at right border in viewer & browser. It is as high as the image is shown and exactly 2px wide. It's not hurting but a little irritating 8) Here it happens in XnView 1.96.5 and also 1.82.
Which theme do you use?
Pierre.

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: Win 7 64bit

Post by GeorgD » Tue Oct 27, 2009 1:09 pm

xnview wrote:Which theme do you use?
Aero-Design "Windows 7". BTW (by the way), in browser the area is plain grey, in viewer it is a weird way of transparent: I see part of the title & scroll bar of another program:
ImageImage
But I have no other program located at that area of screen, attached to top & right border, as you can see: ImageImage
When I click in viewer into that area, I sometimes - but not always, may be dependant on position I click onto, did not yet find a rule - land in XnView browser. The scrollbar position of the browser is related to the one visible in the right area in viewer, so scrollbar in browser on top means scrollbar in viewer on upper part of area, scrollbar in browser on bottom means scrollbar in viewer on lower part of area, but it is not exactly top/bottom in viewer. Maybe the viewer lets the browser "shine through" but without the usual blurring? I'll observe it...
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: problem with Aero theme

Post by GeorgD » Wed Oct 28, 2009 6:28 pm

Today I do not have that bug. No setting was changed, no updated performed. The only thing that is different: Today I did a complete boot, not a hibernate wake-up like before - maybe there was something bad in that stored session... I'll observe and hope to find rules for that bug.
In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

Post Reply