EXIF orientation info is wrong

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
fireattack
Posts: 31
Joined: Sun Nov 10, 2013 8:02 am

EXIF orientation info is wrong

Post by fireattack » Sat May 28, 2016 1:53 am

Example image: http://i.imgur.com/HvBwO16.jpg

It shows 1 (top left):

Image

It should be 6:

Image

Ironically the built-in addon Exiftool shows it correctly:

Image

XnView Classic has the same problem by the way.

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: EXIF orientation info is wrong

Post by xnview » Tue May 31, 2016 1:46 pm

fireattack wrote:Example image: http://i.imgur.com/HvBwO16.jpg
this picture has no exif orientation
Pierre.

fireattack
Posts: 31
Joined: Sun Nov 10, 2013 8:02 am

Re: EXIF orientation info is wrong

Post by fireattack » Tue Jun 14, 2016 8:01 pm

xnview wrote:
fireattack wrote:Example image: http://i.imgur.com/HvBwO16.jpg
this picture has no exif orientation
Sorry, didn't realize Imgur stripped out all the exif info.

Try this one: https://www.dropbox.com/s/cuxm42b1iltlu ... W.jpg?dl=0

User avatar
xnview
Author of XnView
Posts: 32283
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: EXIF orientation info is wrong

Post by xnview » Wed Jul 13, 2016 4:04 pm

See Issue 915 for details.
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5499
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: EXIF orientation info is wrong

Post by XnTriq » Sat Feb 25, 2017 11:15 pm

Confirmed fixed :bugfixed:
:arrow: Moved to “Closed/Resolved”

Post Reply