0.92 Impossible to launch

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
aminatha
Posts: 5
Joined: Wed Nov 28, 2018 7:01 pm

0.92 Impossible to launch

Post by aminatha » Wed Nov 28, 2018 7:13 pm

I tried today to upgrade my xnview.
I can not launch it anymore.
Starting it from the terminal it says :

Code: Select all

root@denebola:/home/nada# cat /etc/debian_version
7.11
root@denebola:/home/nada# uname -r
3.2.0-6-amd64
root@denebola:/home/nada# xnview
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.19' not found (required by /opt/XnView/XnView)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5MultimediaWidgets.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Multimedia.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Widgets.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Gui.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Network.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /opt/XnView/lib/libQt5Core.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Core.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5PrintSupport.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Svg.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQtAVWidgets.so.1)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5WebKitWidgets.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQtAV.so.1)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Concurrent.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Xml.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5OpenGL.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libicui18n.so.56)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libicuuc.so.56)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5WebKit.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Sensors.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /opt/XnView/lib/libavutil.so.56)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Positioning.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Quick.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Qml.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5WebChannel.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /opt/XnView/lib/libQt5Sql.so.5)
/opt/XnView/XnView: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by /opt/XnView/lib/libvdpau.so.1)

I did a lot of researches but I could get any solution....
I installed the libc.so.6 package.
thanks for any track. I'm a beginner and I'm lost !
and of course I really really need this software

User avatar
xnview
Author of XnView
Posts: 30281
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92 Impossible to launch

Post by xnview » Thu Nov 29, 2018 10:33 am

which distribution do you have?
Pierre.

aminatha
Posts: 5
Joined: Wed Nov 28, 2018 7:01 pm

Re: 0.92 Impossible to launch

Post by aminatha » Thu Nov 29, 2018 4:39 pm

Distributor ID: Debian
Description: Debian GNU/Linux 7.11 (wheezy)
Release: 7.11
Codename: wheezy

User avatar
xnview
Author of XnView
Posts: 30281
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92 Impossible to launch

Post by xnview » Fri Nov 30, 2018 7:58 am

and you have no problem with 0.90?
Pierre.

aminatha
Posts: 5
Joined: Wed Nov 28, 2018 7:01 pm

Re: 0.92 Impossible to launch

Post by aminatha » Sat Dec 01, 2018 1:07 pm

I was using 0.63 if I'm not mistaken...

aminatha
Posts: 5
Joined: Wed Nov 28, 2018 7:01 pm

Re: 0.92 Impossible to launch

Post by aminatha » Thu Dec 06, 2018 5:53 pm

je n'ai toujours pas trouvé de soution à ce problème et j'ai vraiment besoin de ce programme
.
Je ne sais vraiment pas quoi faire.
Je suis prêt à tout essayer;
merci pour les idées.

aminatha
Posts: 5
Joined: Wed Nov 28, 2018 7:01 pm

Re: 0.92 Impossible to launch

Post by aminatha » Tue Dec 11, 2018 6:46 pm

I solved my problem with finding the old version 0,64
and it works but I can launch only as super user.
If I launch it as a normal user it says :

Code: Select all

XNVIEW restoreGeometry before : 640 480 
XNVIEW restoreGeometry after : 1364 688 
or, if I'm using a shortcut it says :
XnviewMP : database has a more recent version number than the expected one
Well I can use it now but if there's a solution for this smaller problem I'll be really happy !

User avatar
xnview
Author of XnView
Posts: 30281
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92 Impossible to launch

Post by xnview » Thu Dec 13, 2018 1:24 pm

you need to rename xnview.db, 0.64 is very old version
Pierre.

Post Reply