Auto Correct doesn't work correct-ly

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
m.Th.
XnThusiast
Posts: 1583
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Auto Correct doesn't work correct-ly

Post by m.Th. » Sat Nov 30, 2019 9:05 am

We assume that we have the standard Autocorrect list in which (for example) we have „b&w” to be replaced by „black & white”.

Steps:

1. Select a file
2. Press F2 and the Edit window should appear (assuming that you have checked in Settings the option to appear the Edit window)
3. Go to with the caret AT THE BEGINNING or IN THE MIDDLE of the file name - NOT at the end.
4. Write in the place defined at #3 the text „ b&w ” without quotes and with the necessary spaces in order to have it as a separate word from the other part of the file name.

Expected: „b&w” should be expanded to „black & white”

Actual: Nothing happens

Note: The Auto Correct works correctly only if b&w is at the end of the text, thing which is misleading and confusing. There are many shortcuts which are specifically put at the beginning of the text (for example „Mr” to be expanded to „Mister”, „Ave” to „Avenue”, „Str” to „Street” aso.).
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Auto Correct doesn't work correct-ly

Post by xnview » Fri Dec 06, 2019 11:55 am

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Auto Correct doesn't work correct-ly

Post by xnview » Sun Mar 08, 2020 9:04 am

See issue for current status and some details.
Pierre.

User avatar
xnview
Author of XnView
Posts: 33336
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Auto Correct doesn't work correct-ly

Post by xnview » Sat Mar 21, 2020 9:15 am

This problem is supposed to be fixed in XnView MP 0.96. Please check and confirm the bug fix here.
Pierre.

User avatar
m.Th.
XnThusiast
Posts: 1583
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: Auto Correct doesn't work correct-ly

Post by m.Th. » Sat Mar 21, 2020 4:00 pm

xnview wrote:
Sat Mar 21, 2020 9:15 am
This problem is supposed to be fixed in XnView MP 0.96. Please check and confirm the bug fix here.
Seems to work ok. Thanks a lot!
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

Post Reply