0.84: Image "jumps" when selecting requires scrolling

Moderators: cday, XnTriq, helmut, xnview, Dreamer

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.84: Image "jumps" when selecting requires scrolling

Postby helmut » Tue Feb 21, 2017 11:58 pm

XnView: MP 0.84
OS: Windows 10 - 64bit

When selecting an area of the image and then enhancing the selection towards the top of the image requiring scrolling, the image is suddenly repositioned and seems to "jump".

Effect: Irritating user interface.

To reproduce:
1. Open an medium image (e.g. 1.000 x 1.000 pixels)
2. Zoom into the image (e.g. 400%)
3. Move the image using the hand or the pan tool so that you can see the top right part of the image.
4. On the right side, start a selection and select towards the top so that the mouse cursor "touches" the toolbar and the image starts scrolling.
Actual behaviour (bug): When scrolling the image repositions horizontally all of a sudden and "jumps" to the right. Selection is completely off, now. :bug:

Expected behaviour: When scrolling, the image shouldn't reposition itself horizontally.

Note:
- The problem occurs whenever enhancing the selection beyond the images borders, regardless in which direction.
- The problem occurs both in View mode (Viewer) and in Fullscreen.

vertigo
Posts: 107
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby vertigo » Wed Feb 22, 2017 1:26 am

Reproduced in windowed mode, but not fullscreen. For me, in fullscreen, it just stops at the edge of the screen.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby helmut » Wed Feb 22, 2017 9:14 am

vertigo wrote:Reproduced in windowed mode, but not fullscreen. For me, in fullscreen, it just stops at the edge of the screen.
Thank you for confirming, vertigo!

:arrow: Reproduced

User avatar
xnview
Author of XnView
Posts: 27578
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby xnview » Tue Feb 28, 2017 1:35 pm

i can't reproduce, could you make a video?
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 4965
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86: Selection rectangle on zoomed image

Postby XnTriq » Tue May 09, 2017 4:00 am

xnview wrote:i can't reproduce, could you make a video?

  1. Start XnView MP with its default settings.
  2. Maximize the window.
  3. Activate Show scrollbars in ToolsSettings...ViewView.
  4. Open an image in non-fullscreen view mode.
  5. Use the + keyboard shortcut to zoom into the image until both the vertical and horizontal scrollbar show up.
  6. Move the mouse cursor to the upper left corner of the visible part of the image (i.e. to the left edge of the screen and right below the main toolbar).
  7. Press & hold the left mouse button to make a selection and move the cursor onto XnView's vertical scrollbar.
    :bug: The vertical scrollbar jumps to the top.
  8. Close the image and repeat steps #4 through #6.
  9. Press & hold the left mouse button to make a selection and move the cursor onto XnView's horizontal scrollbar.
    :bug: The horizontal scrollbar jumps to the left.

User avatar
xnview
Author of XnView
Posts: 27578
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby xnview » Sat Jun 17, 2017 6:26 pm

O.k., thank you, I can also reproduce the problem. Issue 1219 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 27578
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby xnview » Sat Jul 08, 2017 12:48 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 4965
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.84: Image "jumps" when selecting requires scrolling

Postby XnTriq » Wed Jul 19, 2017 1:30 am

xnview wrote:This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.

Confirmed fixed :bugfixed:


Return to “0.87 Testing – Fixed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest