0.86: Crash when pressing <Ctrl> + </> in Browser-Mode with folder selected

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

0.86: Crash when pressing <Ctrl> + </> in Browser-Mode with folder selected

Postby Jobi » Mon May 22, 2017 7:37 pm

XnViewMP 0.86 - 64-bit (and earlier versions, at least down to 0.84)
OS: Windows 7 - 64-bit / Windows 8.1 - 64-bit

Effect: XnViewMP crashes when pressing <Ctrl> + </> (numpad) while a folder is selected.

XnViewMP crashes immediately while using the default shortcut <Ctrl> + </> (numpad) for "cmd_realSize" in Browser-mode while a folder is selected.
I realised that a while ago when I tried to expand all folders with <Ctrl> + <×> (numpad) and pressed by accident <Ctrl> + <÷> (numpad).

To reproduce:
1. Browser-mode: Select a folder either from the left folder pane or from the file list
2. Now press <Ctrl> + </> (numpad)
3. XnViewMP will immediately crash

Actual behaviour (bug): XnView crashes :bug:

Expected behaviour: No crash, no action.

With kind regards,
Jobi

User avatar
xnview
Author of XnView
Posts: 27578
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Crash when pressing <Ctrl> + </> in Browser-Mode with folder selected

Postby xnview » Sat Jun 17, 2017 4:54 pm

O.k., thank you, I can also reproduce the problem. Issue 1259 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 27578
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Crash when pressing <Ctrl> + </> in Browser-Mode with folder selected

Postby xnview » Sat Jul 08, 2017 1:00 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

Re: 0.86: Crash when pressing <Ctrl> + </> in Browser-Mode with folder selected

Postby Jobi » Sun Jul 09, 2017 5:39 am

xnview wrote:This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.

I did a quick testing with XnView MP 0.87 beta 1 and do confirm the bug to be fixed. Many thanks for that, Pierre. :)
Kind regards, Jobi


Return to “0.87 Testing – Fixed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest