0.86: Fixed Ratio crop not working

Moderators: cday, XnTriq, helmut, xnview, Dreamer

richlux
Posts: 5
Joined: Fri Jun 30, 2017 12:14 am

0.86: Fixed Ratio crop not working

Postby richlux » Fri Jun 30, 2017 4:48 am

XnView: MP 0.86 - 64 bit
OS: Windows 7 64bit

Fixed ratio cropping does not seem to work. When dragging the selection box, it is locked to some ratio, but it is not the ratio of the current image. It gets worse if you work with multiple images with very different aspect ratios.

Effect: Selected area does not follow aspect ratio of image

To reproduce:
1. Open an image with a large difference between X and Y aspect ratio (e.g. 10:1)
2. Click on the crop icon to enter crop mode
3. Click the left mouse button and start selecting an area. you may notice the area is not locked to the aspect ratio of the image
4. Close the current image and open a new one with a large difference between X and Y aspect ratio opposite the first image (e.g. 1:10)
5. Click the left mouse button and start selecting an area. you may notice the area is still locked to the aspect ratio of the first image or it may not be locked to either of them.

Actual behaviour (bug): Selected area does not match current image aspect ratio

Expected behaviour: Selected area should match current image aspect ratio

Thanks,
Rich

User avatar
xnview
Author of XnView
Posts: 27589
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Fri Jun 30, 2017 12:02 pm

Ok, i'll set the ratio value with ratio of picture
Pierre.

User avatar
xnview
Author of XnView
Posts: 27589
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Fixed Ratio crop not working

Postby xnview » Sat Jul 08, 2017 12:12 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.


Return to “0.87 Testing – Retest (Fixed in Beta 1)”

Who is online

Users browsing this forum: No registered users and 2 guests