Exiftool and filenames with unicode characters

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Exiftool and filenames with unicode characters

Post by herb »

Hello,

this topic is only to inform you, that Exiftool version > 9.79 is able to handle filenames with also unicode characters on windows systems by itself.

Please update to latest Exiftool version.
Instead of sending the windows file-short-name to Exiftool, you have to send the filename UTF-8 encoded to Exiftool.
But you have also to give the option: -charset filename=utf8
To get the real filename also in output of Exiftool will be much better than seeing only the windows file-short-name.

Thanks in advance
Best regards
Herb
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Post by herb »

Hello Pierre,

please enhance XnViewMP with next version.
It looks much better, when also Exiftool displays a correct filename instead of the windows short name.

Best regards
Herb
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Post by herb »

Hello Pierre,

I still hope that XnViewMP (currently 0.87) will be enhanced, so that Exiftool will display the file-long-name (on windows).

Best regards
Herb
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Post by herb »

Hello Pierre,

I still hope that version 0.93 of XnViewMP will be enhanced.
By the way: you can also send the fully qualified filename of a (e.g.) *.orf_original to Exiftool.

Best regards
Herb
User avatar
xnview
Author of XnView
Posts: 34090
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Exiftool and filenames with unicode characters

Post by xnview »

ok i'll check
Pierre.
User avatar
xnview
Author of XnView
Posts: 34090
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Exiftool and filenames with unicode characters

Post by xnview »

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.
herb
Posts: 174
Joined: Sat Jul 18, 2009 3:19 pm

Re: Exiftool and filenames with unicode characters

Post by herb »

Hello Pierre,

a short check with XnViewMP 0.94.1 showed that now also Exiftool displayes filenames with unicode characters.
Thanks for the enhancement/correction.

Best regards
herb
Post Reply