Strange Copy/Paste

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
Piteur
Posts: 285
Joined: Sun Mar 06, 2005 2:43 pm
Location: Europe

Strange Copy/Paste

Post by Piteur » Thu Oct 01, 2015 2:55 pm

Hello.

I use XnViewMP 0.72. Do I see a bug? Imagine a picture; in that picture, a full hight portion (column) is selected for copying. It's copied (CTRL+C). When the selection is moved for pasting, there is a slight upward shift.

Here is a picture where I selected the right side (narrow column); then I pasted it in the middle.
Capture-1.png
Capture-1.png (3.7 KiB) Viewed 656 times
>>> after pasting
Capture-1b.png
Capture-1b.png (4.85 KiB) Viewed 656 times
This peculiarity does not occur in XnView 2.32.

Where is the problem ?

====== EDIT ======

I just installed the version 0.75 (32 bit - Xubuntu). The problem is the same... :|

User avatar
xnview
Author of XnView
Posts: 31272
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Strange Copy/Paste

Post by xnview » Fri Oct 02, 2015 6:55 am

and if you save it, always the problem?
Pierre.

User avatar
Piteur
Posts: 285
Joined: Sun Mar 06, 2005 2:43 pm
Location: Europe

Re: Strange Copy/Paste

Post by Piteur » Fri Oct 02, 2015 12:54 pm

Thank you, Pierre. But not sure I understand: look at the pictures attached to the message, they are saved files ... I swear: no special effects! 8)

When I reopen a file like this, there are no corrections ( :?: :?: :?: )...

Don't you get to reproduce the bug?

Note: when I drag several times selection from left to right (and vice versa) before CTRL + C, selection overflowing down is reduced down by 1 or 2 pixels, then pasting (CTRL + V) is right ...

User avatar
xnview
Author of XnView
Posts: 31272
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Strange Copy/Paste

Post by xnview » Fri Oct 02, 2015 4:14 pm

You copy the right area, and after you paste it, right?
I've tried but no problem??
Pierre.

User avatar
Piteur
Posts: 285
Joined: Sun Mar 06, 2005 2:43 pm
Location: Europe

Re: Strange Copy/Paste

Post by Piteur » Sun Oct 04, 2015 9:13 am

xnview wrote:You copy the right area, and after you paste it, right?
Exactly.
xnview wrote:I've tried but no problem??
Don't understand. :( It's very strange...

====== EDIT ======

I try to reexplain with screenshots :

PICTURE FOR TEST:
Image

SELECTING AND COPYING (full height area):
Capture-1b.png
Capture-1b.png (5.41 KiB) Viewed 581 times
MOVING AREA:
Capture-1c.png
Capture-1c.png (4.73 KiB) Viewed 581 times
PASTING:
Capture-1d.png
Capture-1d.png (7.12 KiB) Viewed 581 times
RESULT:
Image

DETAIL:
Capture-1f.png
Capture-1f.png (1.85 KiB) Viewed 581 times
Problem found many times. No problem few times.

Thanks for helping.

User avatar
xnview
Author of XnView
Posts: 31272
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Strange Copy/Paste

Post by xnview » Mon Oct 05, 2015 8:46 am

right, it's a bug in the move of selection not paste...
Pierre.

User avatar
Piteur
Posts: 285
Joined: Sun Mar 06, 2005 2:43 pm
Location: Europe

Re: Strange Copy/Paste

Post by Piteur » Mon Oct 05, 2015 12:18 pm

xnview wrote:right, it's a bug in the move of selection not paste...
Ok, the bug is identified! :bugconfirmed:

You can get around the problem by "shaking" laterally the selection (using the mouse), before copying... :)

====== EDIT October 29th =======

XnViewMP 0.76.1 (Windows) :

Solved bug, it seems. Thank you, Pierre. :)

Post Reply