[résolu] 0.84: Filtre des catégories: Dossier courant

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
michel038
Posts: 428
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

[résolu] 0.84: Filtre des catégories: Dossier courant

Post by michel038 » Tue Feb 14, 2017 10:39 pm

Subject: Filtre des catégories : Dossier courant
XnView: MP 0.84
OS: Windows 7 - 64 bit
Effect: Aucune photo n'est trouvée si on filtre les catégories dans le dossier courant.

Pour trouver les photos correspondant à une catégorie sélectionnée, on ne peut le faire qu'en sélectionnant "Global" dans le menu "Correspond"

Autres versions :
Le problème était déjà présent en 0.82
J'ai une version 0.78 : là ça fonctionne, le défaut ne se manifeste pas.
Je n'ai pas d'autre version pour faire des tests

Image

To reproduce:
1 : Affecter une catégorie à une image
2 : Dans le menu "correspond" du "filtre des catégories" , sélectionner "dossier courant"
3 : Cliquer la catégorie : Aucune image n'est trouvée.
Last edited by michel038 on Sat Sep 16, 2017 10:30 am, edited 2 times in total.

User avatar
xnview
Author of XnView
Posts: 32726
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by xnview » Wed Feb 15, 2017 8:58 pm

Je ne peux reproduire, en cliquant sur la photo la catégorie est bien associée?
Pierre.

User avatar
michel038
Posts: 428
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by michel038 » Thu Feb 16, 2017 5:47 pm

Oui ... La preuve, c'est que ça fonctionne avec la V0.78

Avec la v0.84
Quand je coche "Global" le filtre trouve bien l'image avec la catégorie correspondante
Quand je coche "Dossier courant" le filtre ne trouve pas d'image ...

Plus généralement, quand "Dossier courant" est coché , le filtre de catégories ne fournit aucun résultat, quelle que soit la catégorie sélectionnée.
Avec "récursif" ce n'est pas mieux, même si je me positionne dans un dossier racine contenant des milliers de photos, toujours aucun résultat.
Je suppose qu'il faut chercher du côté de la notion de "dossier courant" ?

User avatar
xnview
Author of XnView
Posts: 32726
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by xnview » Fri Feb 17, 2017 8:08 am

'dossier courant' est le dossier actuellement visible depuis l'explorateur
Pierre.

User avatar
michel038
Posts: 428
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by michel038 » Fri Feb 17, 2017 6:48 pm

J'ai réinstallé une V0.84 dans un autre dossier : --> le filtre fonctionne !

Je vais refaire différents réglages ou personnalisations pour essayer de déterminer à quel moment le bug apparaît ...


En fait j'ai signalé "ce bug" car un utilisateur qui est confronté à ce problème m'avait contacté par mail ...
et c'est là que je me suis rendu compte que moi aussi j'avais le même.

User avatar
michel038
Posts: 428
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by michel038 » Sat Feb 18, 2017 8:55 pm

Le bug est revenu.

Apparemment c'est en définissant le répertoire de base que le bug apparaît. (Outils, Options, Catalogue)
Dans mon cas, j'avais spécifié un dossier "i:\6 originaux"
... ( quel est l'intérêt de définir ce "répertoire de base" ? )

Workaround Contournement
Donc, dans Outils, Options, Catalogue :

- Je vide la case "répertoire de base pour les images".
- Comme le filtre de catégories ne fonctionne plus du tout, je supprime tous les dossiers dans le tableau "Maintenance cache".
(au fait pourquoi ce nom ? alors qu'il s'agit des dossiers gérés par la base de données si j'ai bien compris ?)
- Je clique "Ajouter" en spécifiant l'emplacement de mon dossier de photos (i:\6 originaux)
- J'attends 40 minutes que quelques dizaines de milliers de photos soient lues, avec l'option "Importer les mots clés XMP ou IPTC dans les catégories DB"

Et là, mon filtre de catégories fonctionne bien.


En résumé, pour mieux décrire le bug , dans mon premier post là haut il faut ajouter une étape avant l'étape 1
0 - renseigner la valeur "répertoire de base pour les images" dans Outils, Options, Catalogue.

User avatar
xnview
Author of XnView
Posts: 32726
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by xnview » Tue Feb 28, 2017 8:09 am

effectivement je corrige Issue 1126
Pierre.

User avatar
xnview
Author of XnView
Posts: 32726
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by xnview » Thu Mar 16, 2017 8:53 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

User avatar
michel038
Posts: 428
Joined: Tue Sep 27, 2016 8:18 am
Location: France
Contact:

Re: 0.84: Filtre des catégories: Dossier courant

Post by michel038 » Sat Sep 16, 2017 10:29 am

Tested version V0.87 = OK , solved !

Thanks

Post Reply