0.85b4: Weird dialogue when renaming Videos in Fullscreen

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

0.85b4: Weird dialogue when renaming Videos in Fullscreen

Post by arspr » Sun Apr 02, 2017 8:53 pm

XnView: MP 0.85 - 64 bit
OS: Windows 10 1607 64bit

A weird dialogue is shown after trying to rename a video in Fullscreen mode. See Attached screenshot.

Effect: What the hell is that?

To reproduce:
1. Go to Fullscreen in a folder which contains videos.
2. Go to any video.
3. Press F2 to rename that video.
4. Rename it, and press enter.

Actual behaviour (bug): The extra dialogue is launched. (As if there's a conflict with something).

Expected behaviour: Nothing should be shown. The video should be renamed as it happens with images.
Attachments
Weird dialogue after trying to rename a video in Fullscreen.jpg

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by helmut » Sun Apr 02, 2017 10:07 pm

Thank you for the bug report, arspr. What you experience is bug #2 reported by Dreamer in topic 0.85b2: Renaming file/folder in use issues.

:arrow: Closed (Duplicate bug report).

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by arspr » Mon Apr 03, 2017 5:32 am

Hi, Helmut.

It's not exactly the same bug. Here, I haven't opened the video file with any external program...

It's a "conflict" of XnView with itself which is absurd. And it doesn't happen with images, only with videos.

But I guess its cause is probably related (or it's just the same one). I'm going to post a link there to this new variant.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by helmut » Mon Apr 03, 2017 7:27 am

arspr wrote:It's not exactly the same bug. Here, I haven't opened the video file with any external program...
Right. And better have several bug reports with various scenarious than just one huge bug report.

:arrow: Reproduced

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by arspr » Tue Apr 04, 2017 9:19 pm

I suppose this is also a variant of the very same issue.

XnView also seems to conflict to itself when trying to batch-rename several videos from Browser. Look at the following screenshots:
Attachments
...you get this error.jpg
...you get this error.jpg (11.36 KiB) Viewed 563 times
Trying to batch rename several video files....jpg

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by arspr » Sun Jul 16, 2017 2:50 pm

arspr wrote:I suppose this is also a variant of the very same issue.

XnView also seems to conflict to itself when trying to batch-rename several videos from Browser. Look at the following screenshots:
Oooops, the problem with batch-rename is alive in 0.87 beta 1, although the very first issue I posted is solved. I've opened a different thread for it.

arspr
Posts: 76
Joined: Sat Mar 25, 2017 12:25 pm

Re: 0.85b4: Weird dialogue when renaming Videos in Fullscree

Post by arspr » Tue Jul 18, 2017 6:56 pm

arspr wrote:
arspr wrote:I suppose this is also a variant of the very same issue.

XnView also seems to conflict to itself when trying to batch-rename several videos from Browser. Look at the following screenshots:
Oooops, the problem with batch-rename is alive in 0.87 beta 1, although the very first issue I posted is solved. I've opened a different thread for it.
Another big OOOOOOPS.

I didn't test properly. I still cannot rename within Player/Fullscreen. But I don't get the "conflict" message but a "generic" one. (Screenshots in the other thread).

Sorry about the misinformation.

Post Reply