Settings > Interface > Mouse > Left button

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
karnak
Posts: 19
Joined: Sat Aug 09, 2014 9:27 pm

Settings > Interface > Mouse > Left button

Post by karnak » Thu Nov 09, 2017 11:01 am

Is there a setting to disable the default Pan with Zoom behavior? Maybe in the .ini file?


Right now I'm forced to set Left button to Do nothing because I don't like the Pan with Zoom behavior.
The things that I don't like about the Pan with Zoom are the following:
  • When I switch mode from Fullscreen to Browser with double left click the image zooms for some milliseconds instead of an instant clean transition to Browser mode.
  • I have an image smaller then my screen. I zoom with + key on the keyboard. The image is still smaller then my screen. The Pan and Zoom behavior set the image to 100% zoom if I Pan. The correct behavior in this case would be to not pan and not change the zoom.

User avatar
xnview
Author of XnView
Posts: 30262
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Settings > Interface > Mouse > Left button

Post by xnview » Thu Nov 16, 2017 7:11 am

ok, i'll add a setting
Pierre.

karnak
Posts: 19
Joined: Sat Aug 09, 2014 9:27 pm

Re: Settings > Interface > Mouse > Left button

Post by karnak » Thu Nov 16, 2017 8:59 am

Thank you for the hard work Pierre.

User avatar
xnview
Author of XnView
Posts: 30262
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Settings > Interface > Mouse > Left button

Post by xnview » Wed Jan 24, 2018 4:11 pm

karnak wrote:Thank you for the hard work Pierre.
i've sent you a PM
Pierre.

User avatar
xnview
Author of XnView
Posts: 30262
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Settings > Interface > Mouse > Left button

Post by xnview » Wed Jan 24, 2018 6:59 pm

See issue for current status and some details. I'll post here once the problem has been fixed.
Pierre.

User avatar
xnview
Author of XnView
Posts: 30262
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Settings > Interface > Mouse > Left button

Post by xnview » Mon Feb 12, 2018 10:12 am

This problem is supposed to be fixed in XnView MP 0.90. Please check and confirm the bug fix here.
Pierre.

karnak
Posts: 19
Joined: Sat Aug 09, 2014 9:27 pm

Re: Settings > Interface > Mouse > Left button

Post by karnak » Mon Feb 12, 2018 11:38 am

I confirm that the issue is fixed (0.90 beta 1).
Thank you!

Post Reply